Bug 604496 - NetworkManager does not notify Evolution for WorkOnline connection to internet via 56K modem.
NetworkManager does not notify Evolution for WorkOnline connection to interne...
Status: CLOSED DUPLICATE of bug 476954
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 00:14 EDT by Wayne Channell
Modified: 2010-06-28 15:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 15:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Response from yum update for evolution.i686 0:2.30.2-1.fc13 (14.02 KB, text/plain)
2010-06-26 18:05 EDT, Wayne Channell
no flags Details

  None (edit)
Description Wayne Channell 2010-06-16 00:14:16 EDT
Description of problem:
Evolution 2.30.1.2 email starts up with the WorkOnline/WorkOffline button greyed out.  The WorkOnline button is not functional, and therefore does not allow the flag to be switched to the WorkOnline mode, even though an active 56K modem is present.  Evolution is unable to connect to an active 56K Modem that has been configured via Network Device Control.  This same active modem functions properly for the FireFox 3.6.3 browser, but will not connect to the Evolution email system.

This same workstation and modem hardware worked properly a few days ago when using Fedora 12.  Very reliable.  This system has been updated with "yum update", using Fedora 13 with this same modem and hardware.  I also used the Export/Import function to transfer the previous Fedora 12 Evolution data (email, contacts, settings, etc) to the new Fedora 13 Evolution software.

Version-Release number of selected component (if applicable):
Network Manager Applet 0.8.0.997
Evolution 2.30.1.2
FireFox 3.6.3

How reproducible:
Always.  The 56K modem is activated first establishing a connection to the server, then Evolution is started.  The File --> WorkOnline button is then selected, however it is greyed out, and remains non-functional.  It appears that Evolution does not detect the internet connection because of a lack of accurate information from Network Manager.

This same modem with yum was used to update the system software.  The modem works fine.  However, the network information from the modem Network Device Control software, to NetworkManager Applet, to Evolution email is not being transmitted accurately.

Steps to Reproduce:
1.  Initiate the 56K modem using Modem Lights 2.30.0
2.  Initiate the Evolution email program.
3.  Attempt to select the WorkOnline button to connect to the internet.  This is always unsuccessful, since the WorkOnline button remains greyed out and is non-functional.
  
Actual results:
The Evolution email system is non-functional since it will not connect to the internet.  The WorkOnline button is greyed out, and is non-functional.  Evolution cannot reach the internet even though an active modem network connection is present.

Expected results:
This workstation has used this same 56K modem, Modem Lights, Network Device Control, and Evolution software over multiple versions for many years to download email.  When Evolution is started, the WorkOnline button is selected and then Evolution connects to the server via the internet.  At this point the Send&Receive button can be selected to download email from the server. It has worked very reliably in the past.

Additional info:
I attempted to convey this information a few days ago in Bug 603238.  How can I get the Evolution package to connect to the internet?  Many thanks.
Comment 1 Wayne Channell 2010-06-26 18:05:17 EDT
Created attachment 427149 [details]
Response from yum update for evolution.i686 0:2.30.2-1.fc13

A new version of evolution is now available.  I tried to update the system and had a few problems.  See attached file.  Thanks.
Comment 2 Dan Williams 2010-06-28 15:44:20 EDT
NM does not yet support POTS dialup connections.  If this is your primary internet connection, you may want to disable NetworkManager on your machine to avoid the issues you mention in this bug (apps not thinking you're online).  You can do that with "chkconfig NetworkManager off" and then rebooting.

*** This bug has been marked as a duplicate of bug 476954 ***

Note You need to log in before you can comment on or make changes to this bug.