Bug 604942 - Patch to make livecd-iso-to-disk work with netinst images.
Summary: Patch to make livecd-iso-to-disk work with netinst images.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Huff
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 530308 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-17 04:11 UTC by Richard Shaw
Modified: 2010-09-16 03:48 UTC (History)
7 users (show)

Fixed In Version: livecd-tools-034-7.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-16 03:48:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (diff -ru) (1.60 KB, patch)
2010-06-17 04:11 UTC, Richard Shaw
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 590391 None None None Never

Internal Trackers: 590391

Description Richard Shaw 2010-06-17 04:11:30 UTC
Created attachment 424664 [details]
Patch (diff -ru)

Description of problem:
Current version does not properly handle netinst ISO's. Specifying repo= to anaconda prevents it from pulling packages from an online source.

Version-Release number of selected component (if applicable):
livecd-tools.x86_64   031-1.fc12.1 

How reproducible:
Always

Steps to Reproduce:
1. Use livecd-iso-to-disk to copy netinst image to USB disk.
2. Attempt install
3.
  
Actual results:
Can't find packages to install

Expected results:
Pull package info from online source

Additional info:

Comment 1 Richard Shaw 2010-06-17 04:22:51 UTC
Forgot to summarize changes...

Added logic to differentiate between a full DVD installer and a netinst image.

Added a few sync calls because in the case of a netinst image the copy was getting completely cached and the program status would incorrectly say it was installing the boot loader when it was actually copying data.

Added bootloader configuration section for "netinst" which would correct the stage2= option instead of removing it and adding a repo= anaconda option.

Comment 2 Jasper O'neal Hartline 2010-08-07 19:06:31 UTC
*** Bug 530308 has been marked as a duplicate of this bug. ***

Comment 3 Jasper O'neal Hartline 2010-08-31 06:40:40 UTC
This report has a patch which is related, this needs closing once we get this patch in to git. 

https://bugzilla.redhat.com/show_bug.cgi?id=590391

These should be merged to work the best for Netinstall.ISO

Comment 4 Bruno Wolff III 2010-09-12 01:42:39 UTC
I committed a modified form of this one. I think the skipcopy test needed to apply to both image types, not just the second type.

Comment 5 Fedora Update System 2010-09-12 04:20:31 UTC
livecd-tools-034-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/livecd-tools-034-1.fc14

Comment 6 Fedora Update System 2010-09-13 18:10:20 UTC
livecd-tools-034-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update livecd-tools'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/livecd-tools-034-2.fc14

Comment 7 Fedora Update System 2010-09-15 03:23:09 UTC
livecd-tools-034-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/livecd-tools-034-7.fc14

Comment 8 Fedora Update System 2010-09-15 06:52:28 UTC
livecd-tools-034-7.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update livecd-tools'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/livecd-tools-034-7.fc14

Comment 9 Fedora Update System 2010-09-16 03:47:13 UTC
livecd-tools-034-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.