This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 604976 - [abrt] crash in openoffice.org-writer-1:3.2.0-12.24.fc13: ibus_connection_call_with_reply_valist
[abrt] crash in openoffice.org-writer-1:3.2.0-12.24.fc13: ibus_connection_cal...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:56d105b0f56408344f79f4ed60c...
:
: 622673 660101 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 03:44 EDT by Tad
Modified: 2010-12-05 20:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-04 00:52:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (38.33 KB, text/plain)
2010-06-17 03:44 EDT, Tad
no flags Details

  None (edit)
Description Tad 2010-06-17 03:44:00 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/swriter.bin -writer file:///tmp/zg%C5%82oszenia%20elektroniczne.doc
component: openoffice.org
crash_function: raise
executable: /usr/lib64/openoffice.org3/program/swriter.bin
global_uuid: 56d105b0f56408344f79f4ed60cde74afb551de9
kernel: 2.6.33.5-112.fc13.x86_64
package: openoffice.org-writer-1:3.2.0-12.24.fc13
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/swriter.bin was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)
Comment 1 Tad 2010-06-17 03:44:02 EDT
Created attachment 424709 [details]
File: backtrace
Comment 2 Caolan McNamara 2010-06-17 03:54:28 EDT
    message=0x2284430 "assertion failed: (ibus_connection_is_connected (connection))") at gtestutils.c:1318

nothing OOo can do about this, ideally shouldn't just immediately die and take that app with it
Comment 3 fujiwara 2010-06-27 22:42:22 EDT
It seems the recent code has the assert when ibus_connection_is_connected() is failed with "RemoveMatch" method:
http://github.com/phuang/ibus/commit/0ac0c0a91d5a50f8286b9aff662a46e51cc8ae6e

But I could not reproduce your bug.
It seems the problem could be happened when you close swriter.
How do you reproduce your problem?
Comment 4 Fedora Admin XMLRPC Client 2010-08-02 02:17:43 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 David Tardon 2010-08-10 03:10:53 EDT
*** Bug 622673 has been marked as a duplicate of this bug. ***
Comment 6 fujiwara 2010-08-25 22:46:26 EDT
How do you reproduce your problem?
Comment 7 fujiwara 2010-09-29 23:39:04 EDT
Any update?
Comment 8 Caolan McNamara 2010-12-05 11:19:50 EST
*** Bug 660101 has been marked as a duplicate of this bug. ***
Comment 9 Caolan McNamara 2010-12-05 11:21:10 EST
From the backtrace its happening at application shutdown, if that helps in anyway.
Comment 10 fujiwara 2010-12-05 20:31:16 EST
(In reply to comment #9)
> From the backtrace its happening at application shutdown, if that helps in
> anyway.

If you can verify the fix, I can provide the scratch build.
I'm not sure if a possible patch can fix your problem since I cannot reproduce the problem.

Note You need to log in before you can comment on or make changes to this bug.