Bug 604997 - Cannot completely disable the userlist in gdm
Summary: Cannot completely disable the userlist in gdm
Status: CLOSED DUPLICATE of bug 606808
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: jmccann
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-17 09:12 UTC by bugreports2005
Modified: 2015-01-14 23:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 20:00:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bugreports2005 2010-06-17 09:12:34 UTC
Description of problem:

The new gdm in RHEL6 beta is designed to display a list of users to pick from. As we have thousands in LDAP and hundreds may use our more public computers, this makes little sense, and we want to disable it. A gconf setting will disable the list, but not the selection of "Other" at its bottom.

Worse yet, should one for example mistype ones password, on the next try gdm will omit even asking for a username. The only option then displayed is a box saying "Other", with no supporting context.

We much miss the functionality of just clearly and simply asking for username and password, like any other login manager we've ever used would.


Version-Release number of selected component (if applicable):
gdm-2.28.2-5.el6.i686


How reproducible:
Always


Steps to Reproduce:
1. install gdm
2. gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults --type bool --set /apps/gdm/simple-greeter/disable_user_list true
3. start gdm

Actual results:

Gdm correctly omits showing the user list, but regardless it shows a seemingly disconnected selectable item of "Other" that makes no sense in the context displayed. At this point it still at least asks for Username.

Now press enter twice to give empty information to the Username and the following Password prompt. The login should fail, and gdm should reset for the next try. Now it will not even ask for a Username unless you click on the inexplicable "Other" first.

Expected results:
gdm clearly asks for the username and password.

Additional info:

Comment 2 RHEL Product and Program Management 2010-06-17 09:33:11 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 jmccann 2010-06-22 16:51:22 UTC
I've tested that this works as expected in recent upstream versions and we'll get the fix in a build soon.

Comment 4 jmccann 2010-06-29 20:00:13 UTC

*** This bug has been marked as a duplicate of bug 606808 ***


Note You need to log in before you can comment on or make changes to this bug.