Bug 606808 - not able to set disable_user_list
not able to set disable_user_list
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: jmccann
desktop-bugs@redhat.com
:
: 604997 610233 613007 613839 (view as bug list)
Depends On:
Blocks: 587794 590948 599016
  Show dependency treegraph
 
Reported: 2010-06-22 10:27 EDT by Tomas Pelka
Modified: 2015-01-14 18:25 EST (History)
11 users (show)

See Also:
Fixed In Version: gdm-2.30.4-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:27:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2010-06-22 10:27:50 EDT
Description of problem:
Even if disable_user_list is true, the user list is still displayed.

Version-Release number of selected component (if applicable):
gdm-2.30.2-8.el6

How reproducible:
100%

Steps to Reproduce:
1. gconftool-2 --type bool --set /apps/gdm/simple-greeter/disable_user_list true
2. gconftool-2 -g /apps/gdm/simple-greeter/disable_user_list
true
3. killall gdm-binary
  
Actual results:
user list is still displayed

Expected results:
no user list should be displayed

Additional info:
Comment 3 RHEL Product and Program Management 2010-06-22 10:53:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 jmccann 2010-06-22 13:37:56 EDT
Is that value being set in the mandatory or default gconf sources?  Or alternately specifically for the gdm user.
Comment 5 Tomas Pelka 2010-06-23 03:29:40 EDT
It was set additionally for normal user, for root and also via gconf-editor.
Comment 6 jmccann 2010-06-29 16:00:13 EDT
*** Bug 604997 has been marked as a duplicate of this bug. ***
Comment 7 Ray Strode [halfline] 2010-06-29 18:30:15 EDT
This should be set in gdm-2.30.4-2.el6
Comment 9 Ray Strode [halfline] 2010-07-08 10:26:34 EDT
*** Bug 610233 has been marked as a duplicate of this bug. ***
Comment 10 Vladimir Benes 2010-07-12 05:34:25 EDT
it's still not working in gdm-2.30.4-6.el6.x86_64 
moving back to ASSIGNED
Comment 11 Vladimir Benes 2010-07-12 05:38:31 EDT
*** Bug 613007 has been marked as a duplicate of this bug. ***
Comment 12 Vladimir Benes 2010-07-12 05:42:10 EDT
as mentioned in bug 613007 
gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults --type bool --set /apps/gdm/simple-greeter/disable_user_list true
command works
Comment 13 Vladimir Benes 2010-07-12 05:45:08 EDT
there is one difference .. the command was executed under root permissions but gconf_editor was executed under normal user's perms.
Comment 14 Ray Strode [halfline] 2010-07-12 10:46:43 EDT
Ah, you can't set it as a normal user.  You either have to set it in one of the system gconf databases or in gdm's gconf database.  Doing it as a normal user makes it touch a gconf database that will never get looked at.

The easiest way to test this is:

1) run gconf-editor
2) navigate to the key
3) check the checkbox
4) right click on the item
5) choose "Set as Default"
6) enter the root password
Comment 15 Vladimir Benes 2010-07-12 11:16:38 EDT
> The easiest way to test this is:
> 
> 1) run gconf-editor
> 2) navigate to the key
> 3) check the checkbox
> 4) right click on the item
> 5) choose "Set as Default"
> 6) enter the root password    

yes, this makes sense .. 
-> VERIFIED
Comment 16 Ray Strode [halfline] 2010-07-12 17:20:24 EDT
*** Bug 610233 has been marked as a duplicate of this bug. ***
Comment 17 Bill Nottingham 2010-07-13 11:13:10 EDT
*** Bug 613839 has been marked as a duplicate of this bug. ***
Comment 18 Gary Gatling 2010-07-27 15:06:09 EDT
spin 2 of beta 2 (gdm-2.30.4-5.el6) fixes the problem so that gdm no longer displays a thin vertical line when /apps/gdm/simple-greeter/disable_user_list is set to true. It appears to behave normally now.
Comment 19 Neal Pape 2010-07-30 11:48:13 EDT
When will the fixed version gdm-2.30.4-2 become available for Fedora?
Comment 20 releng-rhel@redhat.com 2010-11-10 15:27:50 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.