Bug 605164 - RHEL-4.8 32 image could not boot up with latest kernel.
RHEL-4.8 32 image could not boot up with latest kernel.
Status: CLOSED DUPLICATE of bug 606643
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 06:44 EDT by YangFeng
Modified: 2015-04-19 20:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 06:41:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kvmtarce log (7.78 MB, text/plain)
2010-06-17 06:49 EDT, YangFeng
no flags Details

  None (edit)
Description YangFeng 2010-06-17 06:44:01 EDT
Description of problem:
RHEL-4.8 32 image could not boot up after update kernel to latest.

Version-Release number of selected component (if applicable):
Host kernel:
2.6.32-33.el6.x86_64
qemu-kvm version:
qemu-kvm-0.12.1.2-2.73.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start a RHEL-4.8 32 guest os.
'qemu-kvm -name 'vm1' -monitor tcp:0:6001,server,nowait -drive file=RHEL-4.8-32-2.qcow2,if=ide,cache=none,boot=on,aio=native -net nic,vlan=0,model=e1000,macaddr=02:8F:50:B4:3c:42 -net tap,vlan=0,ifname=e1000_0_6001,script=/etc/qemu-ifup-switch,downscript=no,vhost=on -m 2048 -smp 2 -soundhw ac97 -redir tcp:5000::22 -vnc :0 -usbdevice tablet -rtc-td-hack -cpu qemu64,+sse2 -no-kvm-pit-reinjection -serial unix:/tmp/serial-20100613-180943-9cCi,server,nowait
'
2. Update RHEL-4.8 kernel to latest.
'rpm -ivhf http://download.devel.redhat.com/brewroot/packages/kernel/2.6.9/89.28.EL/i686/kernel-smp-2.6.9-89.28.EL.i686.rpm'
3. Reboot RHEL-4.8 32 guest os.
  
Actual results:
RHEL-4.8 32 guest could not boot up successfully. It stop at probing PCI hardware.

Expected results:
RHEL-4.8 32 guest boot up successfully. 

Additional info:
Original kernel in RHEL-4.8 32 image(uname -a):
Linux virtlab-66-84-137.englab.nay.redhat.com 2.6.9-89.EL #1 Mon Apr 20 10:22:29 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Information got from serial port:
ENABLING IO-APIC IRQs

..TIMER: vector=0x31 pin1=2 pin2=-1

checking TSC synchronization across 2 CPUs: 

CPU#0 had -1393445 usecs TSC skew, fixed it up.

CPU#1 had 0 usecs TSC skew, fixed it up.

Brought up 2 CPUs

zapping low mappings.

checking if image is initramfs... it is

Freeing initrd memory: 1560k freed

NET: Registered protocol family 16

PCI: PCI BIOS revision 2.10 entry at 0xffe77, last bus=0

PCI: Using configuration type 1

mtrr: v2.0 (20020519)

mtrr: your CPUs had inconsistent variable MTRR settings

mtrr: your CPUs had inconsistent MTRRdefType settings

mtrr: probably your BIOS does not setup all CPUs.

mtrr: corrected configuration.

ACPI: Subsystem revision 20040816

ACPI: Interpreter enabled

ACPI: Using IOAPIC for interrupt routing

ACPI: PCI Root Bridge [PCI0] (00:00)

PCI: Probing PCI hardware (bus 00)
Comment 2 YangFeng 2010-06-17 06:49:22 EDT
Created attachment 424757 [details]
kvmtarce log
Comment 3 RHEL Product and Program Management 2010-06-17 06:53:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 YangFeng 2010-06-21 05:52:49 EDT
Also meet this bug on kvm-83-164.el5_5.12.
Comment 5 Juan Quintela 2010-06-23 06:41:53 EDT

*** This bug has been marked as a duplicate of bug 606643 ***

Note You need to log in before you can comment on or make changes to this bug.