Bug 60521 - SSL_connect error when using rhn_register
SSL_connect error when using rhn_register
Status: CLOSED DUPLICATE of bug 60826
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-28 17:36 EST by Need Real Name
Modified: 2015-01-07 18:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-05 15:51:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-28 17:36:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
When I use rhn_register from either a shell or Xwindows session the first 
screen loads, then hangs and gives me:

A socket error occured: SSL_connect error, attempt #1 x's 5
 

Version-Release number of selected component (if applicable):
# rhn_register --version 
Red Hat Network Registration Agent v2.7.2 
Copyright (c) 1999-2001 Red Hat, Inc. 
Licensed under terms of the GPL. 

How reproducible:
Always

Steps to Reproduce:
1.run rhn_register
2.sit back
3.watch errors
	

Actual Results:  # rhn_register 
A socket error occured: SSL_connect error, attempt #1 
A socket error occured: SSL_connect error, attempt #2 
A socket error occured: SSL_connect error, attempt #3 
A socket error occured: SSL_connect error, attempt #4 
A socket error occured: SSL_connect error, attempt #5 

Expected Results:  In either a shell or Xwindows session this should allow me 
to register my system so I can use the automatic update features of up2date.

Additional info:

# ipchains -L 
ipchains: Incompatible with this kernel 


# iptables -L 
Chain INPUT (policy ACCEPT) 
target     prot opt source               destination          

Chain FORWARD (policy ACCEPT) 
target     prot opt source               destination          

Chain OUTPUT (policy ACCEPT) 
target     prot opt source               destination          

# rhn_register --version 
Red Hat Network Registration Agent v2.7.2 
Copyright (c) 1999-2001 Red Hat, Inc. 
Licensed under terms of the GPL. 

# rhn_register --configure --nox 

0.enableProxyAuth  No                                                 
1.noSSLServerURL   http://www.rhns.redhat.com/XMLRPC
2.oemInfoFile      /etc/sysconfig/rhn/oeminfo                         
3.enableProxy      No
4.networkSetup     Yes
5.httpProxy
6.proxyUser
7.serverURL         https://www.rhns.redhat.com/XMLRPC
8.proxyPassword
9.debug             No

Enter number of item to edit <return to exit, q to quit without saving>: 


# up2date --configure --nox 
0.storageDir         /var/spool/up2date
1.networkSetup       Yes
2.headerCacheSize    40
3.httpProxy
4.debug              No
5.useGPG             Yes
6.networkRetries     5
7.removeSkipList     ['kernel*']
8.retrieveOnly       No
9.enableProxy        No
10.keepAfterInstall  No
11.proxyPassword
12.proxyUser
13.headerFetchCount  10
14.versionOverride
15.enableProxyAuth   No
16.noSSLServerURL    http://www.rhns.redhat.com/XMLRPC
17.noReplaceConfig   Yes
18.noBootLoader      No
19.systemIdPath      /etc/sysconfig/rhn/systemid                      
20.serverURL         https://www.rhns.redhat.com/XMLRPC
21.pkgSkipList       ['kernel*']
22.adminAddress      ['root@localhost']
23.forceInstall      No
24.fileSkipList      []
25.retrieveSource    No


Enter number of item to edit <return to exit, q to quit without saving>:
Comment 1 Cristian Gafton 2002-04-20 02:57:02 EDT

*** This bug has been marked as a duplicate of 60826 ***

Note You need to log in before you can comment on or make changes to this bug.