Bug 60539 - bug in csh lang startup script
bug in csh lang startup script
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 60748 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-01 09:24 EST by Jeremy Sanders
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-01 09:24:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Sanders 2002-03-01 09:24:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
The /etc/profile.d/lang.csh script in the updated initscripts in the errata has
a bug.

It contains the following:
if ($?GDM_LANG) then
    set sourced=1
    setenv LANG=$GDM_LANG
endif

The setenv LANG=$GDM_LANG is a bug: it sets an environment variable up  called
${LANG=$GDM_LANG} which equals "". This breaks the locale and things in perl,
which use it in preference to $LANG.

This is quite severe, as several perl scripts we use don't work without the fix.

This diff fixes it:

BEGINHERE
--- lang.csh	Fri Mar  1 14:16:50 2002
+++ lang.csh_new	Fri Mar  1 14:22:31 2002
@@ -10,7 +10,7 @@
 
 if ($?GDM_LANG) then
     set sourced=1
-    setenv LANG=$GDM_LANG
+    setenv LANG $GDM_LANG
 endif
 
 if ($sourced == 1) then
ENDHERE


Version-Release number of selected component (if applicable):
initscripts-6.43-1
Comment 1 Bill Nottingham 2002-03-01 12:25:55 EST
Fixed in 6.44-1/6.54-1.
Comment 2 Bill Nottingham 2002-03-05 21:31:52 EST
*** Bug 60748 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.