Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 605612 - [abrt] crash in epiphany-2.30.2-1.fc13: malloc_consolidate: Process /usr/bin/epiphany was killed by signal 11 (SIGSEGV)
[abrt] crash in epiphany-2.30.2-1.fc13: malloc_consolidate: Process /usr/bin/...
Status: CLOSED DUPLICATE of bug 615502
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:e6609d543d6f9407bcfefca28e1...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 07:51 EDT by Mihai Harpau
Modified: 2010-08-13 11:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 11:50:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (42.61 KB, text/plain)
2010-06-18 07:51 EDT, Mihai Harpau
no flags Details

  None (edit)
Description Mihai Harpau 2010-06-18 07:51:09 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: epiphany
component: epiphany
crash_function: malloc_consolidate
executable: /usr/bin/epiphany
global_uuid: e6609d543d6f9407bcfefca28e195f16a71fe251
kernel: 2.6.33.5-124.fc13.x86_64
package: epiphany-2.30.2-1.fc13
rating: 4
reason: Process /usr/bin/epiphany was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
Comment 1 Mihai Harpau 2010-06-18 07:51:11 EDT
Created attachment 425092 [details]
File: backtrace
Comment 2 d. johnson 2010-08-13 11:50:26 EDT
#0  malloc_consolidate (av=0x344b57ae80) at malloc.c:5161
        fb = <value optimized out>
        maxfb = <value optimized out>
        p = 0xffffffffffffe940
        nextp = 0x0
        unsorted_bin = 0x344b57aed8
        first_unsorted = <value optimized out>
        nextchunk = 0x2c2bd40
        size = 46322688
        nextsize = 0
        prevsize = 46322688
        nextinuse = <value optimized out>
        bck = <value optimized out>
        fwd = <value optimized out>
#1  0x000000344b2786c2 in _int_malloc (av=0x344b57ae80, 
    bytes=<value optimized out>) at malloc.c:4373
        nb = 32816
        idx = <value optimized out>
        bin = <value optimized out>
        victim = <value optimized out>
        size = <value optimized out>
        victim_index = <value optimized out>
        remainder = <value optimized out>
        remainder_size = <value optimized out>
        block = <value optimized out>
        bit = <value optimized out>
        map = <value optimized out>
        fwd = <value optimized out>
        bck = <value optimized out>
        errstr = 0x0
#2  0x000000344b279aed in __libc_malloc (bytes=32808) at malloc.c:3660
        ar_ptr = 0x344b57ae80
        victim = <value optimized out>
        hook = <value optimized out>
#3  0x000000344b2a2771 in __alloc_dir (fd=30, close_fd=true, statp=0x0)
    at ../sysdeps/unix/opendir.c:184
        default_allocation = 32768
        small_allocation = 8192
        allocation = 32768
        dirp = <value optimized out>
#4  0x000000344ae7ef79 in fdwalk (child_err_report_fd=33, stdin_fd=-1, 
    stdout_fd=-1, stderr_fd=-1, working_directory=<value optimized out>, 
    argv=0x7fffbe64e6f0, envp=0x2c2bbf0, close_descriptors=1, search_path=0, 
    stdout_to_null=0, stderr_to_null=0, child_inherits_stdin=0, 
    file_and_argv_zero=0, child_setup=0, user_data=0x0) at gspawn.c:925
        fd = <value optimized out>
        rl = {rlim_cur = 0, rlim_max = 0}
        data = 0x3
        open_max = <value optimized out>
        res = 0
        d = <value optimized out>
        cb = 0x7eae0
#5  do_exec (child_err_report_fd=33, stdin_fd=-1, stdout_fd=-1, stderr_fd=-1, 
    working_directory=<value optimized out>, argv=0x7fffbe64e6f0, 
    envp=0x2c2bbf0, close_descriptors=1, search_path=0, stdout_to_null=0, 
    stderr_to_null=0, child_inherits_stdin=0, file_and_argv_zero=0, 
    child_setup=0, user_data=0x0) at gspawn.c:1026
No locals.
#6  0x000000344ae7f6cb in fork_exec_with_pipes (intermediate_child=1, 
    working_directory=0x0, argv=0x7fffbe64e6f0, envp=0x2c2bbf0, 
    close_descriptors=1, search_path=0, stdout_to_null=0, stderr_to_null=0, 
    child_inherits_stdin=0, file_and_argv_zero=0, child_setup=0, 
    user_data=0x0, child_pid=0x0, standard_input=0x0, standard_output=0x0, 
    standard_error=0x0, error=0x7f3c937ab220) at gspawn.c:1283
        pid = 0
        stdin_pipe = {-1, -1}
        stdout_pipe = {-1, -1}
        stderr_pipe = {-1, -1}
        child_err_report_pipe = {-1, 33}
        child_pid_report_pipe = {-1, 35}
        status = 0
#7  0x000000344ae7fd28 in IA__g_spawn_async_with_pipes (
    working_directory=<value optimized out>, argv=<value optimized out>, 
    envp=<value optimized out>, flags=<value optimized out>, 
    child_setup=<value optimized out>, user_data=<value optimized out>, 
    child_pid=0x0, standard_input=0x0, standard_output=0x0, 
    standard_error=0x0, error=0x7f3c937ab220) at gspawn.c:631
        __PRETTY_FUNCTION__ = "IA__g_spawn_async_with_pipes"
#8  0x000000344ae7fe2c in IA__g_spawn_async (
    working_directory=<value optimized out>, argv=<value optimized out>, 
    envp=<value optimized out>, flags=<value optimized out>, 
    child_setup=<value optimized out>, user_data=<value optimized out>, 
    child_pid=0x0, error=0x7f3c937ab220) at gspawn.c:122
        __PRETTY_FUNCTION__ = "IA__g_spawn_async"
#9  0x00007f3c93588133 in plugin_test_appletviewer (
    browserTable=<value optimized out>, pluginTable=<value optimized out>)
    at /usr/src/debug/icedtea6-1.8/plugin/icedteanp/IcedTeaNPPlugin.cc:1501
        error = 0
        command_line = {
          0x2c2b4a0 "/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/../../bin/java", 0x2c2b480 "-version", 0x0}
        environment = 0x2c2bbf0




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 615502 ***

Note You need to log in before you can comment on or make changes to this bug.