Bug 60564 - gdb: "gdb.base/funcargs.exp: continue to call5b (little-endian, sizeoflong != sizeof int)" fails
gdb: "gdb.base/funcargs.exp: continue to call5b (little-endian, sizeoflong !=...
Status: CLOSED DUPLICATE of bug 60589
Product: Red Hat Linux
Classification: Retired
Component: gdb (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Beth Uptagrafft
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-01 12:52 EST by Christopher Holmes
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-01 13:34:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Holmes 2002-03-01 12:52:22 EST
Description of Problem:

gdb: "gdb.base/funcargs.exp: continue to call5b (little-endian, sizeof
long != sizeof int)" fails

Version-Release number of selected component (if applicable):

gdb-5.1-1.src.rpm

How Reproducible:

Always

Steps to Reproduce:

1. rpm -i  gdb-5.1-1.src.rpm 
2. cd /usr/src/redhat/SPECS
3. rpm -ba gdb.spec
4. cd /usr/src/redhat/BUILD/gdb-5.1
5. make -k check
6. review  sum file (./gdb/testsuite/gdb.sum)

Actual Results:

Breakpoint 26, 0x12000198c in call5b (un={u1 = 5, u2 = 438086664197}) at
./gdb.base/funcargs.c:353
353	{un.u1 = 7;}
(gdb) FAIL: gdb.base/funcargs.exp: continue to call5b (little-endian, sizeof
long != sizeof int)

Expected Results:

(gdb) PASS: gdb.base/funcargs.exp: continue to call5b (little-endian, sizeof
long != sizeof int)

Additional Information:
	
Expected result achieved on RH 7.2 on Intel.
Comment 1 Christopher Holmes 2002-03-01 17:04:53 EST

*** This bug has been marked as a duplicate of 60589 ***

Note You need to log in before you can comment on or make changes to this bug.