Bug 643416 - F14 TC1.1 LXDE Spin: Unable to input any character to text box in User Manager screen.
F14 TC1.1 LXDE Spin: Unable to input any character to text box in User Manage...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On: 605675
Blocks: F14-accepted/F14FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2010-10-15 10:58 EDT by masami256
Modified: 2013-07-04 08:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: openbox-3.4.11.2-5.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 05:02:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
User Manager screen (95.19 KB, image/png)
2010-10-15 11:02 EDT, masami256
no flags Details

  None (edit)
Description masami256 2010-10-15 10:58:21 EDT
Description of problem:
F14 TC1.1 LXDE spin isn't able to input any character to text box in User Manager screen. I can input character in "Create User" screen, but "User Manager" screen is not. also, that screen is quite strange. Please see attached file(advanced.png). I could change shell and check on/off to checkbox.
I tested netinst.iso, it doesn't have same issue.  

iso files download from following url.
http://alt.fedoraproject.org/pub/alt/stage/14.TC1.1/Live/

I tested Eee PC4G and virt-manager both are i686 image. 
 
Version-Release number of selected component (if applicable):
firstboot-1.113-4.fc14.i686

How reproducible:
Always.

Steps to Reproduce:
1.Install LXDE spin and reboot your computer.
2.When firstboot is run, click forward button until "Create User" screen. 
3.Fill user id, full name and password in the same screen.
4.Click "Advance..." button.
5.Click "Add User" icon.
6.Input any key to text boxes. 
  
Actual results:
unable to input character

Expected results:
Can enter character

Additional info:
I was preparing this test case.
https://fedoraproject.org/wiki/QA:Testcase_desktop_login
Comment 1 masami256 2010-10-15 11:02:37 EDT
Created attachment 453737 [details]
User Manager screen

file attached.
Comment 2 Adam Williamson 2010-10-15 12:24:35 EDT
I'm guessing this has come from the change to using 'native' window managers (rather than metacity) in the spins...

Christoph, which WM does LXDE spin use for firstboot?

proposing NTH, it's a release criteria issue in a non-default spin.
Comment 3 Christoph Wickert 2010-10-15 13:38:44 EDT
LXDE uses openbox and I guess firstboot does not accept /usr/bin/openbox as the WM. Can you please check if openbox is runnning?

According to bug 605675 this should be fixed in firstboot-1.113-4.fc14 but I haven't found the time to test it. If we cannot get this fixed, I need to add metacity to the spin.
Comment 4 Kevin Kofler 2010-10-15 13:43:13 EDT
/usr/bin/openbox is one of the WMs I added on your request (in firstboot-1.113-4.fc14). There might be a compatibility issue with OpenBox.
Comment 5 Adam Williamson 2010-10-15 13:51:24 EDT
Reviewed at 2010-10-15 blocker meeting, accepted as NTH; if you have a fix available by Monday we can get this into RC1.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Christoph Wickert 2010-10-15 14:13:11 EDT
(In reply to comment #4)
> /usr/bin/openbox is one of the WMs I added on your request (in
> firstboot-1.113-4.fc14).

I am confused. I don't see *any* changes in http://git.fedorahosted.org/git/?p=firstboot.git;a=blob;f=firstboot/xfrontend.py

Site note: Why is the master branch of the http://pkgs.fedoraproject.org/gitweb/?p=firstboot.git not up to date? This is not related this bug, it makes things hard to follow.

> There might be a compatibility issue with OpenBox.

Any ideas how to debug this? 

I'm sorry I didn't have the time to test this earlier, but my dayjob keeps me busy. I will have time to work on this at the weekend.
Comment 7 Kevin Kofler 2010-10-15 14:46:01 EDT
> I am confused. I don't see *any* changes in
> http://git.fedorahosted.org/git/?p=firstboot.git;a=blob;f=firstboot/xfrontend.py

http://pkgs.fedoraproject.org/gitweb/?p=firstboot.git;a=blob;f=firstboot-1.113-kwin.patch;h=c727b41bf30840ad42751b19a5fa6b657dd930e9;hb=543a1ff28e3633bf1a506f869917ac26b841a8b3

The changes haven't been merged into fedorahosted yet.

> Site note: Why is the master branch of the
> http://pkgs.fedoraproject.org/gitweb/?p=firstboot.git not up to date?

The changes have been made only in f14/master at this time. For F15+, we really need to get the Anaconda team to merge that patch into fedorahosted upstream. (I can add the patch to pkgs master, but I'd really prefer not having to deal with that.)
Comment 8 Christoph Wickert 2010-10-15 19:05:25 EDT
Openbox refuses to start because it doesn't know the "--display" parameter:

Loading /lib/kbd/keymaps/i386/qwertz/de.map.gz
Openbox-Message: Invalid command line argument "--display"
Comment 9 Kevin Kofler 2010-10-16 08:53:22 EDT
So I guess adding metacity or xfwm4 (both are listed before openbox in the list of WMs to try for firstboot) to the LXDE spin is probably the only fix which can be made in time for F14.

You will need to push out an openbox update ASAP which either adds support for the --display switch or removes the Provides: firstboot(windowmanager).
Comment 10 Kevin Kofler 2010-10-16 08:57:10 EDT
(The joys of having a modern desktop environment rely on a legacy WM.)
Comment 11 Adam Williamson 2010-10-18 17:23:29 EDT
To get this fixed in RC1 we need the update to be built and submitted to Bodhi today, thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Fedora Update System 2010-10-18 18:32:24 EDT
openbox-3.4.11.2-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openbox-3.4.11.2-5.fc14
Comment 13 Christoph Wickert 2010-10-18 19:29:12 EDT
(In reply to comment #10)
> (The joys of having a modern desktop environment rely on a legacy WM.)

Just because Openbox offers a lot of functionality that was dropped from most 'modern' window managers doesn't mean it is legacy.
Comment 14 Adam Williamson 2010-10-18 20:24:44 EDT
I tested the fix and it looks good; I created a side repo with this openbox build in it and built an LXDE spin using that repo, then did a live install from the LXDE image. In firstboot, the user manager tool comes up with window decorations and can be used properly. openbox itself seems to behave fine too (expected, as it hasn't been changed at all). I +1'ed the update.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Adam Williamson 2010-10-18 20:25:32 EDT
Christoph, can you submit the update to stable so we can pull it in for the RC build? Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Christoph Wickert 2010-10-18 21:15:51 EDT
(In reply to comment #15)
> Christoph, can you submit the update to stable 

No, bodhi does not allow this, we need manual tagging by rel-eng. Ticket at https://fedorahosted.org/rel-eng/ticket/4209
Comment 17 Kevin Kofler 2010-10-19 01:03:52 EDT
We should just karma it up, I bumped it up to 2 now.

And:
> Just because Openbox offers a lot of functionality that was dropped from most
> 'modern' window managers doesn't mean it is legacy.

Indeed that's not the issue, the fact that it DOES NOT OFFER a lot of functionality that is available in most 'modern' window managers (e.g. that --display parameter which is the object of this bug) is what makes it legacy.
Comment 18 Fedora Update System 2010-10-19 05:02:51 EDT
openbox-3.4.11.2-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.