Bug 606021 - openoffice displays embedded bitmaps for ttf fonts in spite fonts.conf
Summary: openoffice displays embedded bitmaps for ttf fonts in spite fonts.conf
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 622135 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-20 00:45 UTC by Dmitri A. Sergatskov
Modified: 2010-08-13 21:24 UTC (History)
2 users (show)

Fixed In Version: openoffice.org-3.2.0-12.29.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 21:24:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of bad fonts in oo.org (39.89 KB, image/png)
2010-06-20 00:45 UTC, Dmitri A. Sergatskov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 112567 None None None Never

Description Dmitri A. Sergatskov 2010-06-20 00:45:36 UTC
Created attachment 425403 [details]
screenshot of bad fonts in oo.org

Description of problem:

Openoffice writer (perhaps the presenter and the spreadsheet too) would display an embedded bitmaps for the ttf fonts that have them in spite of the instruction
in .fonts.conf not to do that. 


Version-Release number of selected component (if applicable):

openoffice.org-writer-3.2.0-12.24.fc13.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Have a ttf font with embedded bitmap available. I used Calibri.
2. Type something in a document with this font. Set fontsize to 14
   or smaller. (In my case starting with size 15 i get a vectorized
   version.)
  
Actual results:

Fonts look bad

Expected results:

Fonts look good

Additional info: Screenshot attached. I triend on different x86_64 hardware
(different graphics card) -- all the same. The problem was not there in FC12.

Comment 1 Caolan McNamara 2010-06-21 08:50:32 UTC
Something doesn't seem right.

Comment 2 Caolan McNamara 2010-06-21 10:01:18 UTC
Sigh, the embeddedbitmap setting basically went missing when the fontconfig integration happened upstream and some rearrangement was necessary to improve performance.

Fix checked in, will be good in >= 3.2.0-12.26

Comment 3 Fedora Update System 2010-08-04 14:44:09 UTC
openoffice.org-3.2.0-12.27.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.27.fc13

Comment 4 Fedora Update System 2010-08-05 23:41:38 UTC
openoffice.org-3.2.0-12.27.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.27.fc13

Comment 5 Caolan McNamara 2010-08-07 15:45:29 UTC
*** Bug 622135 has been marked as a duplicate of this bug. ***

Comment 6 Aaron Schlaegel 2010-08-07 17:41:50 UTC
The testing release, openoffice.org-3.2.0-12.27.fc13, fixed the issue for me.

Comment 7 Fedora Update System 2010-08-09 13:19:19 UTC
openoffice.org-3.2.0-12.29.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.29.fc13

Comment 8 Fedora Update System 2010-08-10 21:45:02 UTC
openoffice.org-3.2.0-12.29.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.29.fc13

Comment 9 Fedora Update System 2010-08-13 21:24:13 UTC
openoffice.org-3.2.0-12.29.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.