Bug 622135 - fontconfig Rules are Ignored and Embedded Bitmaps are Displayed
fontconfig Rules are Ignored and Embedded Bitmaps are Displayed
Status: CLOSED DUPLICATE of bug 606021
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-07 11:27 EDT by Aaron Schlaegel
Modified: 2010-08-07 13:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-07 11:45:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Demonstration of OOo displaying embedded bitmaps, while evince properly ignores them. (401.57 KB, image/png)
2010-08-07 11:27 EDT, Aaron Schlaegel
no flags Details
Demonstration of OOo displaying embedded bitmaps, while evince properly ignores them. (405.18 KB, image/png)
2010-08-07 11:32 EDT, Aaron Schlaegel
no flags Details
OOo file that can show the bug (21.47 KB, application/vnd.oasis.opendocument.text)
2010-08-07 11:33 EDT, Aaron Schlaegel
no flags Details
PDF file exported from OOo file (57.16 KB, application/pdf)
2010-08-07 11:34 EDT, Aaron Schlaegel
no flags Details

  None (edit)
Description Aaron Schlaegel 2010-08-07 11:27:02 EDT
Created attachment 437348 [details]
Demonstration of OOo displaying embedded bitmaps, while evince properly ignores them.

Description of problem:
fontconfig Rules are Ignored and Ugly Embedded Bitmaps are Displayed for Common Fonts. It seems that for common fonts like Microsofts Calibri and Droid Serif, OOo displays the ugly monochromatic embedded bitmaps, even if fontconfig is set to ignore them.

Version-Release number of selected component (if applicable):
`rpm -qa 'openoffice.org*'`
openoffice.org-writer-3.2.0-12.25.fc13.x86_64
openoffice.org-pdfimport-3.2.0-12.25.fc13.x86_64
openoffice.org-writer-core-3.2.0-12.25.fc13.x86_64
openoffice.org-presenter-screen-3.2.0-12.25.fc13.x86_64
openoffice.org-core-3.2.0-12.25.fc13.x86_64
openoffice.org-langpack-en-3.2.0-12.25.fc13.x86_64
openoffice.org-math-core-3.2.0-12.25.fc13.x86_64
openoffice.org-calc-core-3.2.0-12.25.fc13.x86_64
openoffice.org-brand-3.2.0-12.25.fc13.x86_64
openoffice.org-opensymbol-fonts-3.2.0-12.25.fc13.noarch
openoffice.org-impress-3.2.0-12.25.fc13.x86_64
openoffice.org-draw-3.2.0-12.25.fc13.x86_64
openoffice.org-math-3.2.0-12.25.fc13.x86_64
openoffice.org-draw-core-3.2.0-12.25.fc13.x86_64
openoffice.org-graphicfilter-3.2.0-12.25.fc13.x86_64
openoffice.org-impress-core-3.2.0-12.25.fc13.x86_64
openoffice.org-xsltfilter-3.2.0-12.25.fc13.x86_64
openoffice.org-ure-3.2.0-12.25.fc13.x86_64
openoffice.org-calc-3.2.0-12.25.fc13.x86_64

`rpm -qa 'fontconfig*'`
fontconfig-2.8.0-1.fc13.x86_64
fontconfig-devel-2.8.0-1.fc13.x86_64


How reproducible:
Every time.

Steps to Reproduce:
1. Make sure one of the fonts is installed. 
2. Type with the font at a normal font size (the ugly bitmaps are only available at common sizes)
3. Remember how fonts looked back in the early 90's
  
Actual results:
Ugly monochromatic font display

Expected results:
Consistent anti-aliased font display

Additional info:
I am attaching a PDF, OOo, and screenshot of the result.
Comment 1 Aaron Schlaegel 2010-08-07 11:32:36 EDT
Created attachment 437349 [details]
Demonstration of OOo displaying embedded bitmaps, while evince properly ignores them.

The last example was out of sync, but it did show what happens.
Comment 2 Aaron Schlaegel 2010-08-07 11:33:39 EDT
Created attachment 437350 [details]
OOo file that can show the bug
Comment 3 Aaron Schlaegel 2010-08-07 11:34:27 EDT
Created attachment 437351 [details]
PDF file exported from OOo file
Comment 4 Aaron Schlaegel 2010-08-07 11:35:16 EDT
View the screenshot at 100% or the resizing will smooth out the font ugliness.
Comment 5 Caolan McNamara 2010-08-07 11:45:29 EDT
Can you check the test packages mentioned in bug 606021 and see if they fix this for you

*** This bug has been marked as a duplicate of bug 606021 ***
Comment 6 Aaron Schlaegel 2010-08-07 13:42:58 EDT
The testing release, openoffice.org-3.2.0-12.27.fc13, fixed the issue for me.

Note You need to log in before you can comment on or make changes to this bug.