Bug 606078 - Filezilla got segmentation fault when drag & drop
Summary: Filezilla got segmentation fault when drag & drop
Status: CLOSED DUPLICATE of bug 626012
Alias: None
Product: Fedora
Classification: Fedora
Component: filezilla   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nicolas Chauvet (kwizart)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-20 12:23 UTC by Daniele Viganò
Modified: 2010-11-28 17:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-28 17:56:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Filezilla backtrace in gnome-shell env (7.76 KB, text/plain)
2010-06-20 15:54 UTC, Daniele Viganò
no flags Details

Description Daniele Viganò 2010-06-20 12:23:03 UTC
Description of problem:

When I try to transfer a file using drag and drop in Filezilla, from left windows (local folder) to the right one (remote folder) or vice-versa, the program exits with Segmentation fault: (from strace)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Segmentation fault

The transfer is working using "Send" command from menus or drag & dropping from nautilus to the remote folder in filezilla. 

Version-Release number of selected component (if applicable):
kernel-2.6.33.5-124.fc13.x86_64
wxBase-2.8.11-1.fc13.x86_64
wxGTK-2.8.11-1.fc13.x86_64
tinyxml-2.5.3-5.fc12.x86_64
filezilla-3.3.2.1-1.fc13.x86_64

How reproducible:
Always reproducible dragging a file or a folder from left window (local files) to right windows (remote files) or vice-versa

Steps to Reproduce:
1. open filezilla
2. connect to an ftp (or sftp etc..)
3. drag a file from local folder view to remote server
  
Actual results:
Segmentation fault

Expected results:
File transfer from local to remote folder or vv.

Additional info:
Fedora 13 x86_64 up to date with italian locale
Tested on two machines both with pure x86_64 environment (Pentium Dual Core and Core 2 Duo)
http://www.smolts.org/client/show/pub_baa15265-3aaa-4b3c-8376-14889eddabe9

Comment 1 Daniele Viganò 2010-06-20 15:06:46 UTC
More info from dmesg after the segmentation fault:

filezilla[2780]: segfault at 60 ip 00007f2698df5160 sp 00007fff2df9ca20 error 4 in libwx_gtk2u_core-2.8.so.0.7.0[7f2698c0f000+3a5000]

Comment 2 Nicolas Chauvet (kwizart) 2010-06-20 15:19:55 UTC
I wasn't able to reproduce on my system.
Can you submit a backtrace using GDB ?
See http://fedoraproject.org/wiki/StackTraces

Thx for the report.

Comment 3 Daniele Viganò 2010-06-20 15:54:58 UTC
Created attachment 425458 [details]
Filezilla backtrace in gnome-shell env

The backtrace is generated during a gnome-shell session

Comment 4 Daniele Viganò 2010-06-20 15:56:29 UTC
I've found that the sigfault occurs only during gnome-shell sessions. It works with "plain" gnome and with compiz enabled.

Thanks a lot.

Comment 5 Nicolas Chauvet (kwizart) 2010-06-22 12:04:31 UTC
Can you try to reproduce with filezilla-3.3.3-1.fc13 from updates-testing ?

Comment 6 Daniele Viganò 2010-06-23 07:15:07 UTC
Yes, I've tried filezilla-3.3.3-1.fc13 (build 2010-06-21) with the same results:

- Standard GNOME: OK
- Compiz GNOME: OK
- GNOME-shell: segmentation fault with drag & drop

Thanks

Comment 7 Nicolas Chauvet (kwizart) 2010-11-28 17:56:15 UTC

*** This bug has been marked as a duplicate of bug 626012 ***


Note You need to log in before you can comment on or make changes to this bug.