Bug 626012 - [abrt] filezilla-3.3.3-1.fc13: Process /usr/bin/filezilla was killed by signal 11 (SIGSEGV)
[abrt] filezilla-3.3.3-1.fc13: Process /usr/bin/filezilla was killed by signa...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wxGTK (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
abrt_hash:0d85542494871080f51f2d32f7e...
:
: 606078 615845 657953 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-21 09:40 EDT by Brian Millett
Modified: 2010-12-17 01:53 EST (History)
9 users (show)

See Also:
Fixed In Version: wxGTK-2.8.11-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-08 16:34:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.22 KB, text/plain)
2010-08-21 09:40 EDT, Brian Millett
no flags Details

  None (edit)
Description Brian Millett 2010-08-21 09:40:35 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: filezilla
component: filezilla
crash_function: gtk_dnd_window_configure_callback
executable: /usr/bin/filezilla
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: filezilla-3.3.3-1.fc13
rating: 4
reason: Process /usr/bin/filezilla was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1282397979
uid: 500

How to reproduce
-----
1.tried to transfer i file
2.
3.
Comment 1 Brian Millett 2010-08-21 09:40:37 EDT
Created an attachment (id=440112)
File: backtrace
Comment 2 Erik Johnson 2010-08-25 20:41:04 EDT
Package: filezilla-3.3.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Drag file from filesystem on left to ftp on right while transfer in progress
2.???
3.ABRT!


Comment
-----
See #1
Comment 3 Th0ma7 2010-09-02 06:58:37 EDT
Having the exact same problem.  I installed the debuginfo and generated a backtrace using gdb:

Core was generated by `filezilla'.
Program terminated with signal 11, Segmentation fault.
#0  0x00000030e1be6160 in gtk_dnd_window_configure_callback (source=0x7fff89656b00) at src/gtk/dnd.cpp:736
736         source->GiveFeedback( ConvertFromGTK(source->m_dragContext->action) );
Missing separate debuginfos, use: debuginfo-install PackageKit-gtk-module-0.6.6-1.fc13.x86_64 SDL-1.2.14-8.fc13.x86_64 dbus-glib-0.86-4.fc13.x86_64 expat-2.0.1-10.fc13.x86_64 gtk2-engines-2.20.1-1.fc13.x86_64 gvfs-1.6.2-1.fc13.x86_64 ibus-gtk-1.3.6-1.fc13.x86_64 ibus-libs-1.3.6-1.fc13.x86_64 libICE-1.0.6-2.fc13.x86_64 libSM-1.1.0-7.fc12.x86_64 libX11-1.3.1-3.fc13.x86_64 libXau-1.0.5-1.fc12.x86_64 libXcomposite-0.4.1-2.fc13.x86_64 libXcursor-1.1.10-4.fc13.x86_64 libXdamage-1.1.2-2.fc13.x86_64 libXext-1.1.2-2.fc13.x86_64 libXfixes-4.0.4-2.fc13.x86_64 libXi-1.3.2-1.fc13.x86_64 libXinerama-1.1-2.fc13.x86_64 libXrandr-1.3.0-5.fc13.x86_64 libXrender-0.9.5-1.fc13.x86_64 libXxf86vm-1.1.0-1.fc13.x86_64 libcanberra-0.24-1.fc13.x86_64 libcanberra-gtk2-0.24-1.fc13.x86_64 libgcrypt-1.4.5-4.fc13.x86_64 libgpg-error-1.7-1.fc13.x86_64 libjpeg-6b-46.fc12.x86_64 libogg-1.2.0-1.fc13.x86_64 libpng-1.2.44-1.fc13.x86_64 libselinux-2.0.90-5.fc13.x86_64 libtasn1-2.4-2.fc13.x86_64 libtdb-1.2.1-2.fc13.x86_64 libtiff-3.9.4-1.fc13.x86_64 libtool-ltdl-2.2.6-20.fc13.x86_64 libudev-153-3.fc13.x86_64 libuuid-2.17.2-8.fc13.x86_64 libvorbis-1.3.1-1.fc13.x86_64 libxcb-1.5-1.fc13.x86_64 nss-mdns-0.10-8.fc12.x86_64 pixman-0.18.0-1.fc13.x86_64 zlib-1.2.3-23.fc12.x86_64
(gdb) bt
#0  0x00000030e1be6160 in gtk_dnd_window_configure_callback (source=0x7fff89656b00) at src/gtk/dnd.cpp:736
#1  0x00000030dfd51003 in _gtk_marshal_BOOLEAN__BOXED (closure=0x2668220, return_value=0x7fff89657280, n_param_values=<value optimized out>, 
    param_values=0x24bcd50, invocation_hint=<value optimized out>, marshal_data=<value optimized out>) at gtkmarshalers.c:84
#2  0x0000003e9460b98e in IA__g_closure_invoke (closure=0x2668220, return_value=0x7fff89657280, n_param_values=2, param_values=0x24bcd50, 
    invocation_hint=0x7fff89657240) at gclosure.c:767
#3  0x0000003e9461f947 in signal_emit_unlocked_R (node=<value optimized out>, detail=0, instance=0x25161f0, emission_return=0x7fff896573d0, 
    instance_and_params=0x24bcd50) at gsignal.c:3248
#4  0x0000003e94620c29 in IA__g_signal_emit_valist (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=0x7fff89657430) at gsignal.c:2991
#5  0x0000003e946213a3 in IA__g_signal_emit (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>)
    at gsignal.c:3038
#6  0x00000030dfe8190f in gtk_widget_event_internal (widget=0x25161f0, event=0x24a8d50) at gtkwidget.c:4958
#7  0x00000030dfd4916d in IA__gtk_main_do_event (event=0x24a8d50) at gtkmain.c:1601
#8  0x00000030df86039c in gdk_event_dispatch (source=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>)
    at gdkevents-x11.c:2372
#9  0x0000003e92a3bd02 in g_main_dispatch (context=0x1d74920) at gmain.c:1960
#10 IA__g_main_context_dispatch (context=0x1d74920) at gmain.c:2513
#11 0x0000003e92a3fae8 in g_main_context_iterate (context=0x1d74920, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#12 0x0000003e92a3fff5 in IA__g_main_loop_run (loop=0x23d0960) at gmain.c:2799
#13 0x00000030dfd493c7 in IA__gtk_main () at gtkmain.c:1219
#14 0x00000030e1be7838 in wxEventLoop::Run (this=<value optimized out>) at src/gtk/evtloop.cpp:76
#15 0x00000030e1c61deb in wxAppBase::MainLoop (this=0x1d76140) at src/common/appcmn.cpp:312
#16 0x000000300ea963a5 in wxEntry (argc=<value optimized out>, argv=<value optimized out>) at src/common/init.cpp:448
#17 0x00000000004812e4 in main (argc=1, argv=0x7fff89657928) at locale_initializer.cpp:83


Hope this helps!
Comment 4 Th0ma7 2010-09-02 07:07:39 EDT
Note that I'm experiencing the exact same problem using the tar.bz2 package available from filezilla web site using the version 3.3.4.1.

Since this is a real blocker I have also opened a ticket on the filezilla site: http://trac.filezilla-project.org/ticket/5564
Comment 5 Tim Kosse 2010-09-06 17:10:36 EDT
This is not a bug in FileZilla, but instead a bug in wxWidgets.

I have created a patch that fixes this problem, see http://trac.wxwidgets.org/ticket/12447for details.
Comment 6 Nicolas Chauvet (kwizart) 2010-09-06 17:28:35 EDT
Thx for having qualified the problem
Re-assigned to the wxGTK maintainer.
Comment 7 Nicolas Chauvet (kwizart) 2010-11-28 12:56:15 EST
*** Bug 606078 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2010-11-29 12:40:45 EST
wxGTK-2.8.11-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/wxGTK-2.8.11-3.fc14
Comment 9 Fedora Update System 2010-11-29 12:40:56 EST
wxGTK-2.8.11-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/wxGTK-2.8.11-2.fc13
Comment 10 Fedora Update System 2010-11-29 13:42:47 EST
wxGTK-2.8.11-2.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/wxGTK-2.8.11-2.el4
Comment 11 Fedora Update System 2010-11-29 13:42:54 EST
wxGTK-2.8.11-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/wxGTK-2.8.11-2.el5
Comment 12 Nicolas Chauvet (kwizart) 2010-11-30 04:04:10 EST
*** Bug 615845 has been marked as a duplicate of this bug. ***
Comment 13 Nicolas Chauvet (kwizart) 2010-11-30 04:09:05 EST
*** Bug 657953 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2010-11-30 17:22:29 EST
wxGTK-2.8.11-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wxGTK'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/wxGTK-2.8.11-3.fc14
Comment 15 Jaime Acevedo 2010-12-08 06:37:18 EST
Package: filezilla-3.3.3-1.fc14.1
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.drag and drop a file to download
2.
3.
Comment 16 Nicolas Chauvet (kwizart) 2010-12-08 06:41:24 EST
@jaime can you try to reproduce with the wxGTK-2.8.11-3.fc14 package (from updates or updates-testing)
Thx
Comment 17 Fedora Update System 2010-12-08 16:33:50 EST
wxGTK-2.8.11-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-12-08 16:43:11 EST
wxGTK-2.8.11-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2010-12-17 01:50:40 EST
wxGTK-2.8.11-2.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2010-12-17 01:53:26 EST
wxGTK-2.8.11-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.