Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 606185 - [abrt] crash in gdb-7.1-26.fc13: ___printf_fp: Process /usr/bin/gdb was killed by signal 11 (SIGSEGV)
[abrt] crash in gdb-7.1-26.fc13: ___printf_fp: Process /usr/bin/gdb was kille...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
abrt_hash:2ace2d86ef9ef95f4d44d02d09f...
:
: 606472 (view as bug list)
Depends On:
Blocks: 609220
  Show dependency treegraph
 
Reported: 2010-06-21 00:27 EDT by Greg Martyn
Modified: 2010-06-30 11:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: gdb-7.1-27.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 609220 (view as bug list)
Environment:
Last Closed: 2010-06-30 11:09:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (217.30 KB, text/plain)
2010-06-21 00:27 EDT, Greg Martyn
no flags Details

  None (edit)
Description Greg Martyn 2010-06-21 00:27:28 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: gdb -batch -ex 'set debug-file-directory /usr/lib/debug:/var/cache/abrt-di/usr/lib/debug' -ex 'file /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java' -ex 'core-file /var/cache/abrt/ccpp-1277092789-3561/coredump' -ex 'thread apply all backtrace 2048 full' -ex 'info sharedlib' -ex 'print (char*)__abort_msg' -ex 'print (char*)__glib_assert_msg' -ex 'info registers' -ex disassemble
comment: Eclipse crashed (which has been happening a lot). The debug traceback is too big to report though -- abrt doesn't let me. I tried anyway. I opened ABRT to report it, debuginfo packages were downloaded, then got a report that gdb crashed.
component: gdb
crash_function: ___printf_fp
executable: /usr/bin/gdb
global_uuid: 2ace2d86ef9ef95f4d44d02d09f42972e2eed420
kernel: 2.6.33.5-124.fc13.x86_64
package: gdb-7.1-26.fc13
rating: 4
reason: Process /usr/bin/gdb was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
Comment 1 Greg Martyn 2010-06-21 00:27:30 EDT
Created attachment 425521 [details]
File: backtrace
Comment 2 Greg Martyn 2010-06-21 00:29:37 EDT
Package: gdb-7.1-26.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Eclipse crashed (which has been happening a lot). The debug traceback is too big to report though -- abrt doesn't let me. I tried anyway. I opened ABRT to report it, debuginfo packages were downloaded, then got a report that gdb crashed.
Comment 3 Tom Tromey 2010-06-21 17:53:30 EDT
#10 0x0000000000512dd5 in val_print_array_elements (
    type=<value optimized out>, valaddr=0x11e889e0 "", 
    address=140161173391296, stream=0x165c9b0, recurse=41342, 

That "recurse" value points at the problem.

Without more information I would guess that this is one of:

http://sourceware.org/bugzilla/show_bug.cgi?id=9067
http://sourceware.org/bugzilla/show_bug.cgi?id=9167
http://sourceware.org/bugzilla/show_bug.cgi?id=10687
Comment 4 Jan Kratochvil 2010-06-27 13:33:39 EDT
*** Bug 606472 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2010-06-29 19:52:54 EDT
gdb-7.1-27.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gdb-7.1-27.fc13
Comment 6 Fedora Update System 2010-06-30 11:09:05 EDT
gdb-7.1-27.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.