Bug 606418 - Index heading does not contain "id" attribute
Summary: Index heading does not contain "id" attribute
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Publican
Classification: Community
Component: publican   
(Show other bugs)
Version: 1.6
Hardware: All
OS: All
low
medium
Target Milestone: ---
Assignee: Jeff Fearn ๐Ÿž
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-21 15:03 UTC by Jaromir Hradilek
Modified: 2016-06-17 21:07 UTC (History)
6 users (show)

Fixed In Version: 2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 04:16:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jaromir Hradilek 2010-06-21 15:03:55 UTC
Description of problem:
When building the book as html, html-single, or html-desktop, the Index heading does not contain the "id" attribute. As a result, the relevant link in the table of contents does not work.

Version-Release number of selected component (if applicable):
publican 1.6.3

How reproducible:
Always.

Steps to Reproduce:
1. Build the book with "--formats=html-single".
2. Try clicking the "Index" in the table of contents.
3. Observe the source code of the page.
  
Actual results:
The <div class="index" title="Index"> tag does not contain the "id" attribute.

Expected results:
The tag should definitely contain it (e.g., <div class="index" title="Index" id="index">), and clicking the Index in the table of contents should work as expected.

Additional info:
None.

Comment 1 Ruediger Landmann 2010-06-21 22:50:23 UTC

*** This bug has been marked as a duplicate of bug 603950 ***

Comment 2 Jeff Fearn ๐Ÿž 2010-06-22 01:08:04 UTC
This is a different bug.

Comment 3 Jeff Fearn ๐Ÿž 2010-06-22 01:17:22 UTC
Enabled generate.id.attributes for XHTML.

Fixed in build: 1.6.3-0.t117


Note You need to log in before you can comment on or make changes to this bug.