Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 606424 - Running gv on a nonsense file crashes it
Running gv on a nonsense file crashes it
Status: CLOSED DUPLICATE of bug 600926
Product: Fedora
Classification: Fedora
Component: gv (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 11:16 EDT by Horst H. von Brand
Modified: 2010-06-29 17:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 17:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A text file that crashes gv (34 bytes, text/plain)
2010-06-21 11:16 EDT, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2010-06-21 11:16:03 EDT
Description of problem:
By mistake I ran gv on the attached file (one line of text), and it segfaulted.

Version-Release number of selected component (if applicable):
ghostscript-8.71-9.fc14.x86_64

How reproducible:
Always with this file

Steps to Reproduce:
1. gv xxx.ps
2.
3.
  
Actual results:
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-efont-biwidth-medium-r-normal--16-*-*-*-*-*-iso10646-1,-gnu-unifont-medium-r-normal--16-*-*-*-*-*-iso10646-1,-adobe-helvetica-medium-r-normal--14-*-*-*-*-*-*-*,-jis-fixed-medium-r-*--16-*-*-*-*-*-jisx0208.1983-0,-*-*-medium-r-*--16-*-*-*-*-*-*-*,*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Segmentation fault

Expected results:
Warning/error messages are OK (this isn't PostScript!), but SEGV isn't.

Additional info:
Comment 1 Horst H. von Brand 2010-06-21 11:16:44 EDT
Created attachment 425661 [details]
A text file that crashes gv
Comment 2 Horst H. von Brand 2010-06-21 11:19:57 EDT
Sorry, the correct component/version is gv-3.6.91-1.fc14.x86_64. gs does complain, but doesn't crash.
Comment 3 M. Steinborn 2010-06-21 15:33:00 EDT
Well, the crash is already described as bug #600926.

More interesting is that gv complains:

Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string
"-efont-biwidth-medium-r-normal--16-*-*-*-*-*-iso10646-1,-gnu-unifont-medium-r-normal--16-*-*-*-*-*-iso10646-1,-adobe-helvetica-medium-r-normal--14-*-*-*-*-*-*-*,-jis-fixed-medium-r-*--16-*-*-*-*-*-jisx0208.1983-0,-*-*-medium-r-*--16-*-*-*-*-*-*-*,*"
to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
#587349

Not being able to build any fontset, GNU gv quits. Due to bug #587349, GNU gv crashes with a segfault  while quiting.


Currently I cannot say anything aboiut the fonts GNU gv cannot find, but disabling international mode helps - cf Bug #600926.



$ cat > ~/.gv <<EOF
> GV.version: 3.6.7.90
> GV*international: False
> EOF

(in case ~/.gv does not exist)

resp.

echo "GV*international: False" >> ~/.gv

(in case ~/.gv already exists)

will disable international mode. Then the fonts required should be available.



Markus Steinborn
GNU gv maintainer


PS: On CentOS 5.5 (and therefore most likely on RHEL 5.5) international mode works fine if and only if Xaw3d is replaced by a fixed version.
Comment 4 Orion Poplawski 2010-06-29 17:53:03 EDT

*** This bug has been marked as a duplicate of bug 600926 ***

Note You need to log in before you can comment on or make changes to this bug.