Bug 600926 - [abrt] crash in gv-3.6.91-1.fc13: XFindContext: Process /usr/bin/gv was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in gv-3.6.91-1.fc13: XFindContext: Process /usr/bin/gv was kille...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gv (Show other bugs)
(Show other bugs)
Version: 13
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3f31bf73c9906f2d07c22ea56ec...
Keywords:
: 606424 609992 (view as bug list)
Depends On: 587349
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-06 17:53 UTC by Lev
Modified: 2010-07-09 06:01 UTC (History)
7 users (show)

Fixed In Version: gv-3.7.1-1.el4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 18:12:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.03 KB, text/plain)
2010-06-06 17:53 UTC, Lev
no flags Details

Description Lev 2010-06-06 17:53:21 UTC
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/gv /tmp/cdf9920_singleTopPolarization.ps
component: gv
crash_function: XFindContext
executable: /usr/bin/gv
global_uuid: 3f31bf73c9906f2d07c22ea56ecbca195754c69e
kernel: 2.6.33.5-112.fc13.i686
package: gv-3.6.91-1.fc13
rating: 4
reason: Process /usr/bin/gv was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

Comment 1 Lev 2010-06-06 17:53:24 UTC
Created attachment 421627 [details]
File: backtrace

Comment 2 Edward Sheldrake 2010-06-10 16:30:23 UTC
I've seen this bug. The segfault happens on closing gv.

It can be avoided by dropping --enable-international from configure when building gv, or by saving gv options, then adding the line:

GV*international:	False

to your ~/.gv settings file.

Comment 3 M. Steinborn 2010-06-21 12:56:34 UTC
Cause for this bug #587349 - a well known bug in Xaw3d, documented in README.I18N included in the source tarball of GNU gv.

Comment 4 Mark van Rossum 2010-06-28 20:20:08 UTC
Package: gv-3.6.91-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
gv  crashes on exit after viewing eps file

Commandline reports:
   Warning: Missing charsets in String to FontSet conversion

Comment 5 Orion Poplawski 2010-06-29 21:53:03 UTC
*** Bug 606424 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2010-06-30 17:12:59 UTC
gv-3.7.1-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/gv-3.7.1-1.el5

Comment 7 Fedora Update System 2010-06-30 17:13:25 UTC
gv-3.7.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gv-3.7.1-1.fc12

Comment 8 Fedora Update System 2010-06-30 17:13:47 UTC
gv-3.7.1-1.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/gv-3.7.1-1.el4

Comment 9 Fedora Update System 2010-06-30 17:14:10 UTC
gv-3.7.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gv-3.7.1-1.fc13

Comment 10 Orion Poplawski 2010-07-01 16:59:32 UTC
*** Bug 609992 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2010-07-01 18:51:22 UTC
gv-3.7.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gv'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gv-3.7.1-1.fc13

Comment 12 Fedora Update System 2010-07-01 18:58:12 UTC
gv-3.7.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gv'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gv-3.7.1-1.fc12

Comment 13 Fedora Update System 2010-07-02 19:25:07 UTC
gv-3.7.1-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gv'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gv-3.7.1-1.el4

Comment 14 Fedora Update System 2010-07-02 19:25:48 UTC
gv-3.7.1-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gv'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gv-3.7.1-1.el5

Comment 15 Fedora Update System 2010-07-08 18:12:20 UTC
gv-3.7.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-07-08 18:25:34 UTC
gv-3.7.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-07-09 05:58:40 UTC
gv-3.7.1-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-07-09 06:01:04 UTC
gv-3.7.1-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.