Bug 606596 - Problem with /sbin/mkdumprd and Raid5 - Cannot build kdump initrd on a system using RAID5
Problem with /sbin/mkdumprd and Raid5 - Cannot build kdump initrd on a system...
Status: CLOSED DUPLICATE of bug 604055
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 23:19 EDT by Rene Jr Purcell
Modified: 2010-07-01 14:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 14:52:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This fix worked for me, I don't know if it's the right way to do this but it worked. (63.80 KB, application/octet-stream)
2010-06-21 23:19 EDT, Rene Jr Purcell
no flags Details
patch to fix raid (497 bytes, patch)
2010-07-01 14:51 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Rene Jr Purcell 2010-06-21 23:19:18 EDT
Created attachment 425809 [details]
This fix worked for me, I don't know if it's the right way to do this but it worked.

Description of problem:

I followed the howto here (http://fedoraproject.org/wiki/Kernel/kdump) on how to
activate kdump to diagnose kernel panic. When I rebooted I found out that kdump
service was unable to build it's initrd. here's the output.

No kdump initial ramdisk found.                            [WARNING]
Rebuilding /boot/initrd-2.6.33.5-124.fc13.i686.PAEkdump.img
No module raid5 found for kernel 2.6.33.5-124.fc13.i686.PAE, aborting.
Failed to run mkdumprd


Version-Release number of selected component (if applicable):

# uname -r
2.6.33.5-124.fc13.i686.PAE
# cat /etc/redhat-release 
Fedora release 13 (Goddard)
# rpm -qa |grep kexec
kexec-tools-2.0.0-35.fc13.i686


# lsmod |grep raid
raid1                  16661  1 
raid456                54229  1 
async_raid6_recov       4352  1 raid456
async_pq                3423  2 raid456,async_raid6_recov
raid6_pq               78424  2 async_raid6_recov,async_pq
async_xor               2641  3 raid456,async_raid6_recov,async_pq
async_memcpy            1464  2 raid456,async_raid6_recov
async_tx                1981  5
raid456,async_raid6_recov,async_pq,async_xor,async_memcpy

# cat /proc/mdstat 
Personalities : [raid6] [raid5] [raid4] [raid1] 
md1 : active raid1 sda1[0] sdb1[1]
      262132 blocks super 1.0 [2/2] [UU]

md0 : active raid5 sda2[0] sdd1[4] sdc1[2] sdb2[1]
      731801088 blocks super 1.1 level 5, 512k chunk, algorithm 2 [4/4] [UUUU]
      bitmap: 1/2 pages [4KB], 65536KB chunk

# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_rp4-LV_root
                       15G  4.8G  8.6G  36% /
tmpfs                1007M  420K 1007M   1% /dev/shm
/dev/md1              248M   40M  196M  17% /boot
/dev/mapper/vg_rp4-LV_home
                      671G  290G  347G  46% /home


How reproducible:
You need to have a Raid5 on your computer.
Follow the procedure to install and enable kdump
(http://fedoraproject.org/wiki/Kernel/kdump) reboot and try to start the kdump
service.


Steps to Reproduce:
1. Install a Fedora 13 with raid5
2. yum install --enablerepo=fedora-debuginfo --enablerepo=updates-debuginfo
kexec-tools crash kernel-debuginfo
3. add crashkernel=128M to the kernel line in /etc/grub.conf
4. Reboot
5. Try to start the kdump service, look at the output.


  
Actual results:

No kdump initial ramdisk found.                            [WARNING]
Rebuilding /boot/initrd-2.6.33.5-124.fc13.i686.PAEkdump.img
No module raid5 found for kernel 2.6.33.5-124.fc13.i686.PAE, aborting.
Failed to run mkdumprd



Expected results:
mkdumprd built the initrd and the "service" start as it's supposed to.

Additional info:

The problem is fixed I attached the file suggested by Mike T on Freenode. I've replaced my mkdumprd file with the attached one, and everything worked fine.

**If you try to reproduce this you will have problem with the initscript look here for the temporary workaround: https://bugzilla.redhat.com/show_bug.cgi?id=606584
Comment 1 CAI Qian 2010-06-21 23:30:19 EDT
You should try - kexec-tools-2.0.0-33.fc14 which should have the fix already - bug 597588.
Comment 2 Neil Horman 2010-07-01 14:51:13 EDT
Created attachment 428528 [details]
patch to fix raid

yup, the above is the patch that you need (which matches the full mkdumprd you provided).
Comment 3 Neil Horman 2010-07-01 14:52:58 EDT
I've actually got bz604055 that I'm using to pull everything in, so I'll just use that bug for this

*** This bug has been marked as a duplicate of bug 604055 ***

Note You need to log in before you can comment on or make changes to this bug.