Bug 604055 - [RFE] review RHEL kexec-tools BZs that applied to Fedora to avoid regression
[RFE] review RHEL kexec-tools BZs that applied to Fedora to avoid regression
Status: CLOSED DUPLICATE of bug 805784
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Young
Fedora Extras Quality Assurance
: Reopened, TestOnly
: 606584 606596 (view as bug list)
Depends On:
Blocks: 597580
  Show dependency treegraph
 
Reported: 2010-06-15 06:15 EDT by CAI Qian
Modified: 2012-05-21 09:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 09:59:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2010-06-15 06:15:28 EDT
Description of problem:
This is a request for development process improvement that whenever DEV fixed BZs in RHEL that those patches should also be considering for Fedora.
Comment 1 CAI Qian 2010-06-15 10:26:31 EDT
Americo, Linda told me to assign this one to you, so we can probably use it to deal with the rest of patches in RHEL but also need in Fedora here. :)
Comment 2 Neil Horman 2010-07-01 14:52:58 EDT
*** Bug 606596 has been marked as a duplicate of this bug. ***
Comment 3 Neil Horman 2010-07-01 14:53:27 EDT
*** Bug 606584 has been marked as a duplicate of this bug. ***
Comment 4 Neil Horman 2011-04-25 09:18:30 EDT
do we have a list of patches here that needs forward porting?
Comment 5 CAI Qian 2011-04-25 20:40:24 EDT
Not at the top of my head. Amerigo should know better than me.
Comment 6 Neil Horman 2011-04-26 07:06:38 EDT
Well, this bug isn't useful unless we have a list of such patches.  Re-assigning to amerigo since he's taking over the fedora branch.
Comment 7 Fedora Admin XMLRPC Client 2011-07-15 11:01:44 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Américo Wang 2011-07-21 12:45:23 EDT
We will rewrite mkdumprd in Fedora 16, so this BZ doesn't apply any more and can be closed.
Comment 9 CAI Qian 2011-07-21 20:22:57 EDT
Well, this is still applied. This is a placeholder to review the existing BZ/patches we fixed in RHEL to make sure the Fedora version did not regress on them especially there were tons of corner cases. It is not matter if we rewrite mkdumprd or not, the concept still apply. We should try to avoid the past mistake that Fedora version has one time contained 60+ regression that we had already fixed in RHEL but forgot to fix here.
Comment 10 Américo Wang 2011-07-21 21:37:54 EDT
Then report new bugs, instead of using this BZ with a confusing title.
Comment 11 CAI Qian 2011-07-22 03:59:06 EDT
Sure, there is no need to open another BZ. If you don't like the title, we can always adjust it.
Comment 12 Américo Wang 2011-07-22 04:43:58 EDT
You don't get the point, nor you understand what "rewrite" means.

Take a look at the latest mkdumprd in git, *none* of RHEL patches can be applied. After we finish rewriting, if there are still some bugs you concern, report new BZ as other normal bugs. There is no reason to keep this one, especially when we are rewriting the code for rawhide.
Comment 13 CAI Qian 2011-07-22 05:45:44 EDT
Let's make this a Test Only BZ assigned to one of our testers.
Comment 14 Fedora Admin XMLRPC Client 2012-04-16 02:12:26 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 15 CAI Qian 2012-05-21 09:59:03 EDT

*** This bug has been marked as a duplicate of bug 805784 ***

Note You need to log in before you can comment on or make changes to this bug.