Bug 606615 - [abrt] crash in telepathy-butterfly-0.5.11-1.fc13: text.py:167:_signal_text_received:UnicodeDecodeError: 'ascii' codec can't decode byte 0xec in position 0: ordinal not in range(128)
Summary: [abrt] crash in telepathy-butterfly-0.5.11-1.fc13: text.py:167:_signal_text_r...
Status: CLOSED DUPLICATE of bug 690809
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly   
(Show other bugs)
Version: 13
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c256eabb
Keywords:
: 608162 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-22 04:32 UTC by scumbag
Modified: 2011-05-29 23:24 UTC (History)
77 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-29 23:24:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.84 KB, text/plain)
2010-06-22 04:32 UTC, scumbag
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 28747 None None None Never

Description scumbag 2010-06-22 04:32:53 UTC
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/libexec/telepathy-butterfly
component: telepathy-butterfly
executable: /usr/libexec/telepathy-butterfly
kernel: 2.6.33.4-95.fc13.i686
package: telepathy-butterfly-0.5.11-1.fc13
reason: text.py:167:_signal_text_received:UnicodeDecodeError: 'ascii' codec can't decode byte 0xec in position 0: ordinal not in range(128)
release: Fedora release 13 (Goddard)

backtrace
-----
text.py:167:_signal_text_received:UnicodeDecodeError: 'ascii' codec can't decode byte 0xec in position 0: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/papyon/switchboard_manager.py", line 369, in _sb_message_received
    handler._on_message_received(message)
  File "/usr/lib/python2.6/site-packages/papyon/conversation.py", line 362, in _on_message_received
    self._dispatch("on_conversation_message_received", sender, msg)
  File "/usr/lib/python2.6/site-packages/papyon/event/__init__.py", line 44, in _dispatch
    if event_handler._dispatch_event(name, *args):
  File "/usr/lib/python2.6/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
    handler(*params)
  File "/usr/lib/python2.6/site-packages/butterfly/channel/text.py", line 295, in on_conversation_message_received
    self._signal_text_received(id, timestamp, handle, type, 0, message.display_name, content)
  File "/usr/lib/python2.6/site-packages/butterfly/channel/text.py", line 167, in _signal_text_received
    headers[dbus.String('sender-nickname')] = dbus.String(sender_nick)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xec in position 0: ordinal not in range(128)

Local variables in innermost frame:
sender: <butterfly.handle.ButterflyContactHandle object at 0x8d2f54c>
text: u'vamos a esa madre, no seas joto'
self: <butterfly.channel.im.ButterflyImChannel at /org/freedesktop/Telepathy/Connection/butterfly/msn/XXXXXXXXXX_40hotmail_2ecom/TextChannel3 at 0x8c59bec>
sender_nick: '\xec\xbf\xa0\xec\xb4\x88'
headers: dbus.Dictionary({dbus.String(u'pending-message-id'): dbus.UInt32(0L), dbus.String(u'message-received'): dbus.UInt64(1277179161L), dbus.String(u'message-type'): dbus.UInt32(0L), dbus.String(u'message-sender'): dbus.UInt32(48L)}, signature=dbus.Signature('sv'))
flags: 0
timestamp: 1277179161
type: 0
id: 0

comment
-----
A contact with this nickname: 

쿠초

Try to start a converstation, actually the conversation starts but in a separate (not in the "all my conversations") window.

Comment 1 scumbag 2010-06-22 04:32:56 UTC
Created attachment 425825 [details]
File: backtrace

Comment 2 Einar Uvsløkk 2010-06-22 16:15:10 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----



Comment
-----
Same as allways. Either not doing anything or receives message over msn protocol

Comment 3 Einar Uvsløkk 2010-06-23 13:35:00 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. receive message over msn protocol


Comment
-----
Same as allways. Either not doing anything or receives message over msn protocol

Comment 4 Hongwen Qiu 2010-06-25 09:34:21 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Receive a message from another msn account.
2.
3.

Comment 5 scumbag 2010-06-28 04:31:19 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
A contact with this nickname:

쿠초

Starts a conversation, the window open and the chat starts but this crash appear.

Comment 6 scumbag 2010-07-01 04:42:35 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
Once again, the contact with this nick:

쿠초

The contact try to start a conversation, and the crash appear, by the way, empathy  and telepathy don't exit, and the conversation window start without problem, but the abrt report appear.

Comment 7 Benjamín Valero Espinosa 2010-07-06 17:36:37 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
It seems that the problem comes because the nickname of buddy has strange characters.

Comment 8 Ricardo Arguello 2010-07-09 06:38:32 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Run Telephaty
2. Crash

Comment 9 Thomas Dall'Agnese 2010-07-11 15:14:51 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Receive a message from a contact in Empathy (from MSN)
2.
3.

Comment 10 Richard 2010-07-13 09:07:52 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. start Empathy
2. ask someone to send you a message
3. but it happened many times, I am not sure when, sometimes it happened when Empathy just finished starting.

Comment 11 Thomas Dall'Agnese 2010-07-14 18:19:45 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Receive a message from a contact in Empathy (from MSN)
2.
3.

Comment 12 simon.marillet 2010-07-15 18:47:39 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.open empathy
2.start a conversation (everything's ok)
3.start a second conversation: send a message (ok), receive a message --> crash

Comment 13 Benjamín Valero Espinosa 2010-07-24 18:52:45 UTC
I have found an upstream bug with the same problem

https://bugs.freedesktop.org/show_bug.cgi?id=28747

where I give a possible fix.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 14 Brian Pepple 2010-07-24 19:44:05 UTC
*** Bug 608162 has been marked as a duplicate of this bug. ***

Comment 15 romythepirate 2010-07-27 00:24:28 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Received message from a contact tru empathy
2.
3.

Comment 16 Engle 2010-08-05 01:15:43 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Run Empathy IM Client, and login in yahoo and msn.
2.The telepathy-butterfly will crash.
3.

Comment 17 Leif H. 2010-08-07 20:20:33 UTC
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
bug when : Chat->Quit

Comment 18 Pablo 2010-08-18 17:58:45 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Recieved an im
2.
3.

Comment 19 Peter Hjalmarsson 2010-08-23 13:23:27 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Recieved a message (possibly a offline message)

Comment 20 Benjamín Valero Espinosa 2010-08-23 19:53:27 UTC
It has been solved in git master:

http://git.collabora.co.uk/?p=telepathy-butterfly.git;a=commitdiff;h=397f50a7018af53cd5fff17fcd4110ce05e5d7f8

It is a pity, because it has been solved just in the following commit after releasing 0.5.13. Would it be possible to apply this patch and updating the package?

Comment 21 nicofo 2010-08-23 21:06:04 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. just open empathy
2. begin a chat
3.

Comment 22 FAZ 2010-08-24 15:27:23 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. just logged back from suspend..
2.
3.


Comment
-----
I really dont know anymore it always crashes...

Comment 23 tttt8 2010-08-24 17:28:08 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
'Someoneelse' sent me a message and the crash just happened.

Comment 24 Bugreporta 2010-08-24 18:31:51 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Just general messaging. No video messaging etc.. I wasn't the person on the machine so can't shed any further light. Mozilla Firefox also in use at the same time.

Comment 25 Ricardo Rivas Gonzalez 2010-08-27 18:07:42 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.When I get a new instant message from msn account
2.
3.

Comment 26 Baris Cicek 2010-08-30 07:28:01 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Received a message.
2.
3.


Comment
-----
Just received a message. But the text appears in the bug report is from a previous discussion, not related to the message I received and triggered bug.

Comment 27 D.S. Ljungmark 2010-09-01 06:07:04 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Start empathy
2. recieve offline message from MSN user
3.  Watch icon pop up.

Comment 28 eduardovra 2010-09-09 21:29:18 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
I happens everytime I use Empathy.

Comment 29 Yorkim Parmentier 2010-09-11 07:46:14 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. I did nothing special, I just started with chatting. 
2. De bug doens't cause thelepathy to crash. It just starts the Automatic Bug Reporting Tool
3.

Comment 30 Andres Rios 2010-09-12 03:59:19 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Don't know
2.
3.

Comment 31 Theophanis Kontogiannis 2010-09-21 12:21:30 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Loged into my account

Comment 32 vitor.dominor 2010-09-24 22:02:57 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Didn't notice any crash.

Comment 33 Lancelot Mak 2010-09-25 03:47:46 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.
2.
3.
just start......with offline unicode message incoming

Comment 34 Lancelot Mak 2010-09-29 01:49:57 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.
2.
3.
just running

Comment 35 Guilherme 2010-09-29 19:30:48 UTC
Package: telepathy-butterfly-0.5.12-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Após inicializar o Empathy e iniciar um bate-papo
2.
3.

Comment 36 Brian Pepple 2011-05-29 23:24:21 UTC

*** This bug has been marked as a duplicate of bug 690809 ***


Note You need to log in before you can comment on or make changes to this bug.