Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 608162 - [abrt] crash in telepathy-butterfly-0.5.11-1.fc13: text.py:170:_signal_text_received:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd9 in position 0: ordinal not in range(128)
[abrt] crash in telepathy-butterfly-0.5.11-1.fc13: text.py:170:_signal_text_r...
Status: CLOSED DUPLICATE of bug 606615
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
abrt_hash:45c042b9
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 16:43 EDT by islam fouda
Modified: 2010-07-24 15:44 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-24 15:44:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.25 KB, text/plain)
2010-06-25 16:43 EDT, islam fouda
no flags Details

  None (edit)
Description islam fouda 2010-06-25 16:43:44 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/python /usr/libexec/telepathy-butterfly
component: telepathy-butterfly
executable: /usr/libexec/telepathy-butterfly
kernel: 2.6.33.5-124.fc13.i686.PAE
package: telepathy-butterfly-0.5.11-1.fc13
reason: text.py:170:_signal_text_received:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd9 in position 0: ordinal not in range(128)
release: Fedora release 13 (Goddard)
Comment 1 islam fouda 2010-06-25 16:43:52 EDT
Created attachment 426986 [details]
File: backtrace
Comment 2 Robert Zhang 2010-06-27 22:08:19 EDT
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.open empathy
2.empathy reports a few messages that were sent to me while i was offline.
3.a few seconds later crash!
Comment 3 Volans 2010-07-04 16:12:44 EDT
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Crash occured when I signed in and got an offline message from MSN.
2.
3.
Comment 4 zaterio 2010-07-04 20:34:57 EDT
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Just Open Empathy (MSN)
2.
3.
Comment 5 Roumano 2010-07-05 06:46:56 EDT
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. do nothing
2.
3.
Comment 6 yyetim 2010-07-05 15:23:44 EDT
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Created MSN account
2. Receveived an offline message
3.
Comment 7 jackonweb 2010-07-08 21:38:32 EDT
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.ABRT pop-up after a new message received
2.
3.
Comment 8 akneto 2010-07-11 10:14:40 EDT
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Just tried to connect to MSN network with empathy!
2.
3.
Comment 9 Kai.Fan 2010-07-20 12:02:07 EDT
Package: telepathy-butterfly-0.5.11-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. startup empathy
2. got an offline message
3.
Comment 10 Benjamín Valero Espinosa 2010-07-24 14:52:40 EDT
Looking the backtrace, it seems that the problem happens when the text of the message has non-Latin characters.

I have found an upstream bug with a similar problem (in the same block of code)

https://bugs.freedesktop.org/show_bug.cgi?id=28747

where I give a possible fix.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Brian Pepple 2010-07-24 15:44:05 EDT

*** This bug has been marked as a duplicate of bug 606615 ***

Note You need to log in before you can comment on or make changes to this bug.