Bug 606987 - SVN integration broken
Summary: SVN integration broken
Keywords:
Status: CLOSED DUPLICATE of bug 651815
Alias: None
Product: Fedora
Classification: Fedora
Component: meld
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-22 21:03 UTC by Tim Jackson
Modified: 2011-03-13 17:45 UTC (History)
3 users (show)

Fixed In Version: meld-1.3.1-3.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-23 05:00:46 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 597718 None None None Never

Description Tim Jackson 2010-06-22 21:03:25 UTC
Description of problem:
The normal meld behaviour that, when you're using an SVN checkout, automatically diffs a modified file in a working copy against the base revision, isn't working in Fedora 13.

Version-Release number of selected component (if applicable):
meld-1.3.1-1.fc13.noarch

How reproducible:
Always

Steps to Reproduce:
1. Check out an SVN working copy from an SVN repository somewhere
2. Modify a file (let's call it "foo")
3. Run "meld foo" from the working copy directory

Actual results:
Meld opens with a blank screen. Console shows:
Traceback (most recent call last):
  File "/usr/share/meld/task.py", line 130, in iteration
    ret = task()
  File "/usr/share/meld/vcview.py", line 353, in run_diff_iter
    diff = difffunc()
  File "/usr/share/meld/vcview.py", line 419, in _command_iter
    r = readfunc()
  File "/usr/share/meld/misc.py", line 209, in __call__
    self.proc = subprocess.Popen(command, cwd=workdir, stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
  File "/usr/lib64/python2.6/subprocess.py", line 621, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1126, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory: ''


Expected results:
Meld opens the file "foo", showing the difference between the modified version and the original one as checked out.

Comment 1 Eric Springer 2010-09-07 04:56:33 UTC
I had this same problem, and fixed with "yum install patch". Can you confirm its the same with you?


And perhaps the meld maintainer could add this as a dependency :D

Comment 2 Tim Jackson 2010-09-09 17:31:22 UTC
No, I already had patch installed. However, I have investigated more and this seems to be GNOME bug 597718. The patch from the upstream bugtracker (http://bugzilla-attachments.gnome.org/attachment.cgi?id=145236) fixes it for me. Brian, please could this be applied to the Fedora meld?

Comment 3 Brian Pepple 2010-09-10 13:05:12 UTC
(In reply to comment #2)
> No, I already had patch installed. However, I have investigated more and this
> seems to be GNOME bug 597718. The patch from the upstream bugtracker
> (http://bugzilla-attachments.gnome.org/attachment.cgi?id=145236) fixes it for
> me. Brian, please could this be applied to the Fedora meld?

Yeah I can, thanks for taking the time to look into this.

Comment 4 Fedora Update System 2010-09-11 16:05:04 UTC
meld-1.3.1-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/meld-1.3.1-3.fc13

Comment 5 Fedora Update System 2010-09-15 05:32:17 UTC
meld-1.3.1-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update meld'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/meld-1.3.1-3.fc13

Comment 6 Fedora Update System 2010-09-23 05:00:41 UTC
meld-1.3.1-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Dominic Hopf 2011-03-13 17:45:58 UTC

*** This bug has been marked as a duplicate of bug 651815 ***


Note You need to log in before you can comment on or make changes to this bug.