Bug 60702 - not statically linked
Summary: not statically linked
Status: CLOSED DUPLICATE of bug 60701
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: busybox (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-05 00:52 UTC by Matt Selsky
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-05 00:52:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matt Selsky 2002-03-05 00:52:26 UTC
/sbin/busybox should be statically linked, not dynamically linked.

From the source rpm, it looks like the file busybox-static.patch contains the
wrong thing.  I looked at the srpm for busybox-0.51.xxx and it contains what
looks like the proper patch file for static linking.

This breaks anything boot/rescue disk which is relying on busybox not needing
other libraries.

Comment 1 Bill Nottingham 2002-03-28 22:46:42 UTC

*** This bug has been marked as a duplicate of 60701 ***


Note You need to log in before you can comment on or make changes to this bug.