Bug 60704 - Foomatic upgrade breaks ljet4 printers
Summary: Foomatic upgrade breaks ljet4 printers
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: foomatic (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-05 03:40 UTC by fred-m
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-03 00:46:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lpq.0 printer log when printing after update (6.25 KB, patch)
2002-03-05 03:42 UTC, fred-m
no flags Details | Diff

Description fred-m 2002-03-05 03:40:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i686; U;) Gecko/20020205

Description of problem:
After upgrading a friend's computer to foomatic-1.1-0.20011218.3 (and all other
updates up to Feb 22), printing stopped completely (no output regardless of file
type or originating application). The printer is a HP LaserJet 6L (using the
ljet4 driver) connected to the parallel port. It was working correctly before
the upgrade with foomatic-1.1-0.20011018.7 (apart from bug 58319).

I attached below the lpq.0 file which shows an error in ghostscript.

This problem did not happen in two other systems that I upgraded (HP DeskJet
970Cxi using the hpijs driver and connected to USB, and an Epson LP-9200SX using
the escpage driver and connected to the network).

I corrected the problem by deleting the printer and re-defining it on
printconf-gui, and now printing works as before the
upgrade. Apparently the changes in foomatic on the ljet4 driver made
the original configuration invalid.

(It would be nice if the fact that the printer needs to be  
re-configured was added to the update announcement).


Version-Release number of selected component (if applicable):
foomatic-1.1-0.20011218.3

How reproducible:
Always

Steps to Reproduce:
1. Define a ljet4 printer with foomatic-1.1-0.20011018.7 or earlier
2. Upgrade to foomatic-1.1-0.20011218.3
3. Try to print anything


Actual Results:  Does not print anything, regardless of the application or data
format.

Expected Results:  Should print what was sent to printer.


Additional info:

Comment 1 fred-m 2002-03-05 03:42:55 UTC
Created attachment 47401 [details]
lpq.0 printer log when printing after update

Comment 2 Tim Waugh 2002-03-05 10:02:14 UTC
Work-around noted.  I'll take a look.  Thanks for reporting it.

Comment 3 Tim Waugh 2002-03-08 15:23:30 UTC
I've had a couple of goes at reproducing this, but without any luck.  The only
difference I see after upgrading is the '[ESC]%-12345X' at the beginning to
signify PJL encapsulation (which wasn't being done properly with the as-shipped
packages).

Reconfiguring (by deleting, applying changes, and re-adding the queue with the
same settings) has no effect on the output.

Since ghostscript complains about paper size in your attachment, let me ask:
what paper size are you using? (I tried US Letter and A4, with the same results.)

Comment 4 fred-m 2002-03-11 09:01:14 UTC
Paper size is A4. This, and the locale (ja_JP) were the only two changes that I
made to the defaults, IIRC. My main source of my suspicion that the bug is in
foomatic is the fact that the list of drivers for the HP LaserJet 6L (and many
other HP printers) changed with the update.

This computer belongs to a friend, and I'll put my hands again on it later this
month and try to reproduce the bug again. If you have suggestions for
tests/setups, please tell me.

(Or, just change the bug to closed state, since the resolution is simple, and
I'm sure that there are other bugs with higher priority... I reported it mainly
so that other people with the same problem could find the resolution).

Comment 5 fred-m 2002-06-03 00:46:41 UTC
In the end I upgraded the machine to Red Hat 7.3 (to solve bugs like 58319,
which I reported -- BTW, it was solved in 7.3, thanks!!!). Since it's now
impossible to try to reproduce this bug, please close it. I'll keep an eye on
this (and other) printer problems and open new bugs if necessary.

Comment 6 Tim Waugh 2002-06-10 09:53:10 UTC
Okay, thanks for letting me know.


Note You need to log in before you can comment on or make changes to this bug.