Bug 607159 - Continuing libgcrypt threading issue
Continuing libgcrypt threading issue
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:47f1ad37290ac89ce326d61004b...
: Reopened
: 607240 612078 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 08:09 EDT by Mads Kiilerich
Modified: 2010-10-08 16:55 EDT (History)
6 users (show)

See Also:
Fixed In Version: cups-1.4.4-9.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 02:20:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (287.16 KB, text/plain)
2010-06-23 08:09 EDT, Mads Kiilerich
no flags Details
attempt at reproducer (but doesn't work) (1.26 KB, text/plain)
2010-09-16 12:29 EDT, Tim Waugh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Novell 617026 None None None Never
CUPS Bugs and Features 3605 None None None Never

  None (edit)
Description Mads Kiilerich 2010-06-23 08:09:05 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.6/firefox
component: firefox
executable: /usr/lib/firefox-3.6/firefox
global_uuid: 47f1ad37290ac89ce326d61004b7a145c153a2be
kernel: 2.6.33.5-112.fc13.i686.PAE
package: firefox-3.6.3-4.fc13
rating: 3
reason: Process /usr/lib/firefox-3.6/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
Firefox crashed when I pressed ctrl+p to print. I think it happened twice, and this is the second time it crashed.

There seems to be some embedded python in the stack, and it recurses "inifitely" on:
  File "/usr/share/glib-2.0/gdb/gobject.py", line 45, in is_g_type_instance_helper
    return is_g_type_instance_helper(first_field.type)
Comment 1 Mads Kiilerich 2010-06-23 08:09:09 EDT
Created attachment 426247 [details]
File: backtrace
Comment 2 Mads Kiilerich 2010-06-23 11:34:21 EDT
*** Bug 607240 has been marked as a duplicate of this bug. ***
Comment 3 Mads Kiilerich 2010-06-23 11:40:59 EDT
This is fully reproducible for me right now - see bug 607240 which for some reason got a different abrt hash and thus wasn't filed as duplicate ...

Printing from for example gedit works fine.
Comment 4 David 2010-06-23 19:15:19 EDT
Package: firefox-3.6.3-4.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Try to print page from firefox
2. Boom
3.
Comment 5 Mads Kiilerich 2010-06-23 19:43:21 EDT
Oh - so I'm not alone on this one. Nice to know. 

On further investigation:
I see crashes with cups*-1.4.4-3.fc13.i686 from updates-testing.

After
yum --disablerepo=updates-testing downgrade 'cups*'
I get cups*-1.4.3-6.fc13.i686 instead, and then it works fine.

Do you other reporters also have update-testing enabled and can you confirm that the problem goes away by downgrading cups*?

I will reassign to cups and vote on https://admin.fedoraproject.org/updates/cups-1.4.4-3.fc13
Comment 6 David 2010-06-23 20:01:10 EDT
Can we get a fixed cups into updates-testing to fix this? Or if there is a new one in koji can it be pushed straight to updates-testing for tomorrows repo cache?
Comment 7 David 2010-06-23 20:07:51 EDT
I also gave negative karma to it in admin updates. Please build a -4 and fix the bug.
Comment 8 Michal Schmidt 2010-06-24 03:25:49 EDT
Opening print preview in Firefox crashes it perfectly reproducibly here. After "yum downgrade cups cups-libs" to 1.4.3 it works again.
Comment 9 Tim Waugh 2010-06-24 05:03:55 EDT
OK.  The history behind this is that gnutls has no way of making its use of libgcrypt thread-safe when used from a library (see bug #553834 and bug #569803).  As a result, CUPS 1.4.4 refuses to link against gnutls in this situation.

Unfortunately, it seems that linking against openssl also fails for some reason.  I think the safest thing to do right now is to switch back to gnutls. :-(
Comment 10 Tim Waugh 2010-06-24 08:06:56 EDT
Novell's bugzilla instance is also tracking this so I've added a reference.

I tried just switching to gnutls and it made no difference(!).  What does seem to work is configuring with '--disable-threads --enable-gnutls', so we'll go with that.
Comment 11 Tim Waugh 2010-06-24 08:29:47 EDT
I've created a separate update.  Please try it out.
https://admin.fedoraproject.org/updates/cups-1.4.4-4.fc13
Comment 12 Michal Schmidt 2010-06-24 08:48:46 EDT
cups-1.4.4-4.fc13 fixes the crash in Firefox print preview for me.
Comment 13 David 2010-07-01 03:30:35 EDT
Agreed 100% fixed in -4
Comment 14 Mads Kiilerich 2010-07-01 04:47:22 EDT
Tim, it seems like you forgot to add this issue on https://admin.fedoraproject.org/updates/cups-1.4.4-5.fc13 (now in request for stable)
Comment 15 Tim Waugh 2010-07-01 07:46:47 EDT
Yes, forgot.  I'll update the status by hand though.
Comment 16 Tim Waugh 2010-09-15 10:42:38 EDT
Re-opening to track the regression caused by --disable-threads.
Comment 17 Tim Waugh 2010-09-15 10:42:52 EDT
*** Bug 612078 has been marked as a duplicate of this bug. ***
Comment 18 Tim Waugh 2010-09-15 11:31:50 EDT
The original gnutls issue: bug #544619.
Comment 19 Tim Waugh 2010-09-15 11:36:02 EDT
And the underlying libgcrypt issue: bug #569803.
Comment 20 Tim Waugh 2010-09-15 11:58:28 EDT
I'm building a cups-1.4.4-8.fc12 package which hopefully addresses this for Fedora 12.  Would love extra testing on it before I merge the change to the other branches...
Comment 21 Jiri Popelka 2010-09-16 10:15:50 EDT
I was not able to reproduce (bug #612078, comment #30) the crash in F12 so I can't verify that cups-1.4.4-8.fc12 fixes it.
So I merged the changes into F13, built cups-1.4.4-10.fc13 and I can verify that it fixes bug #612078 and I can also print from firefox-3.6.7-1.fc13
Comment 22 Tim Waugh 2010-09-16 11:21:50 EDT
Thanks.  When I was testing a F13 merge this morning I did get a Firefox crash while loading the print dialog, but I haven't been able to get it to happen since.

Digging into gcrypt to try to get a patch for the right fix available for review.
Comment 23 Jiri Popelka 2010-09-16 11:31:56 EDT
(In reply to comment #22)
> When I was testing a F13 merge this morning I did get a Firefox crash
> while loading the print dialog,
me too when I built cups locally (fedpkg local), however after building in mock it's ok.
Comment 24 Tim Waugh 2010-09-16 12:28:45 EDT
My crash was from a mock build. :-(

I wish we could get a reliable reproducer to demonstrate the problem, which I still believe is present.  So far my simple attempt (attached) doesn't crash.
Comment 25 Tim Waugh 2010-09-16 12:29:27 EDT
Created attachment 447790 [details]
attempt at reproducer (but doesn't work)
Comment 26 Tim Waugh 2010-09-17 09:57:11 EDT
I've put in a mutex protecting all our calls into gnutls, and taken out the GCRYCTL_SET_THREAD_CBS call altogether.  So far it's looking good in my local testing of a mock build, in that I haven't managed to get Firefox to crash on Ctrl-P yet.

Koji builds building now:

cups-1.4.4-9.fc12
cups-1.4.4-10.fc13
Comment 27 Fedora Update System 2010-09-17 12:38:06 EDT
cups-1.4.4-10.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/cups-1.4.4-10.fc14
Comment 28 Fedora Update System 2010-09-17 12:40:14 EDT
cups-1.4.4-10.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/cups-1.4.4-10.fc13
Comment 29 Fedora Update System 2010-09-17 12:41:30 EDT
cups-1.4.4-9.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/cups-1.4.4-9.fc12
Comment 30 Fedora Update System 2010-09-20 14:39:48 EDT
cups-1.4.4-10.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/cups-1.4.4-10.fc14
Comment 31 Fedora Update System 2010-09-24 16:43:30 EDT
cups-1.4.4-10.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Tim Waugh 2010-09-27 11:05:29 EDT
Re-opening for F-12 and F-14.
Comment 33 Fedora Update System 2010-09-30 02:19:22 EDT
cups-1.4.4-10.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 34 Fedora Update System 2010-10-08 16:55:06 EDT
cups-1.4.4-9.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.