Bug 612078 - multiple system-config-printer threads in _cupsStrAlloc() or malloc()
Summary: multiple system-config-printer threads in _cupsStrAlloc() or malloc()
Status: CLOSED DUPLICATE of bug 607159
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a3d60bea2df07ba931c98013f1e...
Keywords:
: 611199 612494 613895 614970 615518 615726 616295 617827 621049 623925 627921 629394 629592 630819 630916 632440 633182 633345 637577 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 09:28 UTC by Frantisek Hanzlik
Modified: 2010-10-13 15:11 UTC (History)
24 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-09-15 14:42:52 UTC


Attachments (Terms of Use)
File: backtrace (60.08 KB, text/plain)
2010-07-07 09:28 UTC, Frantisek Hanzlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 636488 None None None Never

Description Frantisek Hanzlik 2010-07-07 09:28:26 UTC
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: python /usr/share/system-config-printer/system-config-printer.py
comment: s-c-p crashed when trying change existing SMB printer
component: system-config-printer
crash_function: _cupsStrAlloc
executable: /usr/bin/python
global_uuid: a3d60bea2df07ba931c98013f1e3bc64baa4acbb
kernel: 2.6.33.5-124.fc13.i686
package: system-config-printer-1.2.3-3.fc13
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
Not sure

Comment 1 Frantisek Hanzlik 2010-07-07 09:28:28 UTC
Created attachment 430005 [details]
File: backtrace

Comment 3 Jiri Popelka 2010-07-07 14:12:32 UTC
Ahoj Franto,

are you able to reproduce it or did it happen only once ?

What does 'locale' command show ? 

Would be great if you can attach output from Printing troubleshooter ?
https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter
thanks

Comment 5 Frantisek Hanzlik 2010-07-08 00:22:47 UTC
Hello Jirko,

2) It happen only once, after I changed in "system-config-printer" for local printer "LJ3030" its destination from "smb://GROUP/PC-HRUSKOVA/HP3030" to "smb://GROUP/PC-HRUSKOVA/LJ3030". Change was successfull, but then when I click on window closing point at upper right area, this apps crashed.

2) of course, locale isn't "zh_CN":
# locale
LANG=cs_CZ.utf8
LC_CTYPE="cs_CZ.utf8"
LC_NUMERIC="cs_CZ.utf8"
LC_TIME="cs_CZ.utf8"
LC_COLLATE="cs_CZ.utf8"
LC_MONETARY="cs_CZ.utf8"
LC_MESSAGES="cs_CZ.utf8"
LC_PAPER="cs_CZ.utf8"
LC_NAME="cs_CZ.utf8"
LC_ADDRESS="cs_CZ.utf8"
LC_TELEPHONE="cs_CZ.utf8"
LC_MEASUREMENT="cs_CZ.utf8"
LC_IDENTIFICATION="cs_CZ.utf8"
LC_ALL=
(both system-wide setting in /etc/sysconfig/i18n and all users settings has this locale)

3) I had this F13 i386 machine fully available this (in Czech rep.) prolonged weekend, now i can access it only remote and with low-bandwidth connection. And unfortunatelly employee which is working at W7 WS where is this printer is at vacation, thus this workstation and printer will be on at next week. And it look as "Printing troubleshooter" need access to this printer. Please tell me if this output is still desired.

Comment 6 Jiri Popelka 2010-07-08 10:29:45 UTC
(In reply to comment #5)
> And it look as "Printing troubleshooter" need access to this printer.
Yes, you need to print something to obtain useful info.

> Please tell me if this output is still desired.    
For me it looks like some memory corruption in system-config-printer or cups,
so I don't think there would be anything useful in the output.
Let's wait for Tim (he's also on vacation at the moment),
maybe he'll have some idea what happened.

Comment 7 Jiri Popelka 2010-07-08 12:21:27 UTC
*** Bug 612494 has been marked as a duplicate of this bug. ***

Comment 8 Jiri Popelka 2010-07-08 12:21:45 UTC
*** Bug 611199 has been marked as a duplicate of this bug. ***

Comment 9 Jiri Popelka 2010-07-13 08:23:43 UTC
*** Bug 613895 has been marked as a duplicate of this bug. ***

Comment 10 Jiri Popelka 2010-07-20 07:19:40 UTC
*** Bug 614970 has been marked as a duplicate of this bug. ***

Comment 11 Jiri Popelka 2010-07-20 07:29:13 UTC
*** Bug 615518 has been marked as a duplicate of this bug. ***

Comment 12 Jiri Popelka 2010-07-20 07:33:56 UTC
*** Bug 615726 has been marked as a duplicate of this bug. ***

Comment 13 Jiri Popelka 2010-07-20 09:47:28 UTC
*** Bug 616295 has been marked as a duplicate of this bug. ***

Comment 14 Jiri Popelka 2010-07-26 08:55:41 UTC
*** Bug 617827 has been marked as a duplicate of this bug. ***

Comment 15 Jiri Popelka 2010-08-04 09:29:14 UTC
*** Bug 621049 has been marked as a duplicate of this bug. ***

Comment 16 Ken Simeon 2010-08-10 00:10:09 UTC
Package: system-config-printer-1.2.3-3.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Duplicate an existing printer
2. Configure it wrong so it can't connect properly
3. Click "Change" for "Make and Model"
4. Allow the system to search
5) system-config-printer crashed while trying to find the right drivers for a printer it couldn't connected to.


Comment
-----
 I was attempting to search for the proper drivers of a printer that didn't get properly connected

Comment 17 Jiri Popelka 2010-08-17 10:47:50 UTC
*** Bug 623925 has been marked as a duplicate of this bug. ***

Comment 18 Jiri Popelka 2010-08-27 12:54:46 UTC
*** Bug 627921 has been marked as a duplicate of this bug. ***

Comment 19 Joe Christy 2010-08-31 20:03:03 UTC
Package: system-config-printer-1.2.3-3.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. 
2. 
3.

Comment 20 Jiri Popelka 2010-09-02 09:38:12 UTC
*** Bug 629394 has been marked as a duplicate of this bug. ***

Comment 21 Jiri Popelka 2010-09-06 14:40:50 UTC
*** Bug 629592 has been marked as a duplicate of this bug. ***

Comment 22 Adam Wagner 2010-09-06 19:22:08 UTC
Package: system-config-printer-1.2.3-3.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. I opened the 'add new printer' dialog
2. selected my usb printer that appeared in the list
3. clicked next/add printer


Comment
-----
I did notice that I must have selected the print and clicked the next/add printer button before the 'in progress' indicator finished.  I tried a second time, but this time I waited till the animation stopped, then it worked successfully.

Comment 23 Jiri Popelka 2010-09-07 08:37:44 UTC
*** Bug 630819 has been marked as a duplicate of this bug. ***

Comment 24 Jiri Popelka 2010-09-07 11:17:48 UTC
*** Bug 630916 has been marked as a duplicate of this bug. ***

Comment 25 Jiri Popelka 2010-09-13 12:18:57 UTC
*** Bug 632440 has been marked as a duplicate of this bug. ***

Comment 26 Jiri Popelka 2010-09-13 12:41:54 UTC
*** Bug 633182 has been marked as a duplicate of this bug. ***

Comment 27 Jiri Popelka 2010-09-13 15:55:16 UTC
*** Bug 633345 has been marked as a duplicate of this bug. ***

Comment 28 Tim Waugh 2010-09-15 14:29:31 UTC
The root cause of the problem is that there are two threads in malloc at once because CUPS has been compiled without thread-safety checks since cups-1.4.4-4.

Comment 29 Tim Waugh 2010-09-15 14:42:52 UTC

*** This bug has been marked as a duplicate of bug 607159 ***

Comment 30 Jiri Popelka 2010-09-16 14:14:37 UTC
Steps to reproduce:
(1) Start s-c-p
(2) Press '+Add' button
(3) Fill the password if asked
(4) In devices select parallel or serial port
(5) click 'Forward' button
(6) click 'Cancel' button in 'Searching for drivers' dialog
(7) go to (5)

Comment 31 Jiri Popelka 2010-10-13 15:11:03 UTC
*** Bug 637577 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.