Bug 607246 - [abrt] kernel: WARNING: at arch/x86/kernel/cpu/mtrr/generic.c:467 generic_get_mtrr+0x11e/0x140() (Not tainted)
[abrt] kernel: WARNING: at arch/x86/kernel/cpu/mtrr/generic.c:467 generic_get...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
abrt_hash:1458244125
:
: 651180 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 11:42 EDT by Brock Organ
Modified: 2011-10-14 13:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-05 10:23:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (800 bytes, text/plain)
2010-06-23 11:42 EDT, Brock Organ
no flags Details
File: backtrace (810 bytes, text/plain)
2011-02-14 21:37 EST, Red Hat Case Diagnostics
no flags Details
File: backtrace (827 bytes, text/plain)
2011-04-14 06:59 EDT, Red Hat Case Diagnostics
no flags Details
File: backtrace (1.90 KB, text/plain)
2011-05-31 07:25 EDT, Red Hat Case Diagnostics
no flags Details
File: backtrace (845 bytes, text/plain)
2011-07-01 21:07 EDT, Red Hat Case Diagnostics
no flags Details
File: backtrace (846 bytes, text/plain)
2011-09-09 12:06 EDT, Red Hat Case Diagnostics
no flags Details
File: backtrace (846 bytes, text/plain)
2011-09-19 18:28 EDT, Red Hat Case Diagnostics
no flags Details
File: backtrace (2.00 KB, text/plain)
2011-10-12 13:49 EDT, Red Hat Case Diagnostics
no flags Details
File: backtrace (2.03 KB, text/plain)
2011-10-14 13:04 EDT, Red Hat Case Diagnostics
no flags Details

  None (edit)
Description Brock Organ 2010-06-23 11:42:22 EDT
abrt version: 1.1.4
architecture: x86_64
cmdline: not_applicable
component: kernel
executable: kernel
kernel: 2.6.32-37.el6.x86_64
package: kernel
reason: WARNING: at arch/x86/kernel/cpu/mtrr/generic.c:467 generic_get_mtrr+0x11e/0x140() (Not tainted)
release: Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)
How to reproduce: not sure what events led to the crash

backtrace
-----
WARNING: at arch/x86/kernel/cpu/mtrr/generic.c:467 generic_get_mtrr+0x11e/0x140() (Not tainted)
Hardware name: 649325U
mtrr: your BIOS has set up an incorrect mask, fixing it up.
Modules linked in:
Pid: 0, comm: swapper Not tainted 2.6.32-37.el6.x86_64 #1
Call Trace:
[<ffffffff8106a703>] warn_slowpath_common+0x83/0xc0
[<ffffffff8106a7a1>] warn_slowpath_fmt+0x41/0x50
[<ffffffff8102b9ee>] generic_get_mtrr+0x11e/0x140
[<ffffffff818e5bbb>] mtrr_cleanup+0x8c/0x405
[<ffffffff818e49f1>] ? get_mtrr_state+0x2ec/0x2fb
[<ffffffff818e4535>] mtrr_bp_init+0x1ab/0x1d2
[<ffffffff818dfeba>] setup_arch+0x4b8/0xa9e
[<ffffffff814d761d>] ? printk+0x41/0x44
[<ffffffff818dab75>] start_kernel+0xdc/0x40d
[<ffffffff818da33a>] x86_64_start_reservations+0x125/0x129
[<ffffffff818da438>] x86_64_start_kernel+0xfa/0x109
Comment 1 Brock Organ 2010-06-23 11:42:24 EDT
Created attachment 426294 [details]
File: backtrace
Comment 3 RHEL Product and Program Management 2010-06-23 11:52:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Prarit Bhargava 2010-07-05 10:23:27 EDT
This warning points to a bad bios which has set up the mtrr values incorrectly.  The kernel was able to detect the bad setting and fix it.

Maybe FW_BUG is appropriate here ... but this is not a bug.

P.
Comment 5 James M. Leddy 2010-11-08 17:52:33 EST
*** Bug 651180 has been marked as a duplicate of this bug. ***
Comment 6 James M. Leddy 2010-12-17 12:54:23 EST
*** Bug 651180 has been marked as a duplicate of this bug. ***
Comment 7 Red Hat Case Diagnostics 2011-02-14 21:37:31 EST
Created attachment 478751 [details]
File: backtrace
Comment 9 Red Hat Case Diagnostics 2011-04-14 06:59:03 EDT
Created attachment 492038 [details]
File: backtrace
Comment 12 Red Hat Case Diagnostics 2011-05-31 07:25:56 EDT
Created attachment 501972 [details]
File: backtrace
Comment 16 Red Hat Case Diagnostics 2011-07-01 21:07:05 EDT
Created attachment 510954 [details]
File: backtrace
Comment 20 Red Hat Case Diagnostics 2011-09-09 12:06:26 EDT
Created attachment 522360 [details]
File: backtrace
Comment 24 Red Hat Case Diagnostics 2011-09-19 18:28:57 EDT
Created attachment 523923 [details]
File: backtrace
Comment 28 Red Hat Case Diagnostics 2011-10-12 13:49:47 EDT
Created attachment 527754 [details]
File: backtrace
Comment 32 Red Hat Case Diagnostics 2011-10-14 13:04:16 EDT
Created attachment 528242 [details]
File: backtrace

Note You need to log in before you can comment on or make changes to this bug.