Bug 607502 - Window title
Window title
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: im-chooser (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
: 635955 (view as bug list)
Depends On:
Blocks: 634146
  Show dependency treegraph
 
Reported: 2010-06-24 05:33 EDT by Michael Monreal
Modified: 2010-12-07 15:15 EST (History)
3 users (show)

See Also:
Fixed In Version: im-chooser-1.4.0-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-29 16:29:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (17.95 KB, image/png)
2010-10-20 04:10 EDT, Akira TAGOH
no flags Details

  None (edit)
Description Michael Monreal 2010-06-24 05:33:33 EDT
The im-chooser window currently displays "IM Chooser - Input Method confi"

a) the title is cut off and the window cannot be resized
b) the window should not show branding ("IM Chooser")
c) the window title should be the same as used the .desktop launcher (=> "Input Method" or, as a control center module "Input Method Preferences"
Comment 1 Akira TAGOH 2010-06-24 05:54:41 EDT
Thanks for the feedbacks.

For reference, is there any guidelines for a kind of this issue?

FWIW c) sounds misleading of this functionality to me. im-chooser doesn't behaves either of "Input Method" nor "Input Method Preferences" - "Input Method" would be like ibus and scim and "Input Method Preferences" would be a specific one for them. this is to switch, disable/enable the Input Method. this is why currently it displays "Input Method configuration tool" as the title. though it may be too long. so further idea to improve the window title is welcome :)
Comment 2 Michael Monreal 2010-06-24 06:20:50 EDT
The GNOME HIG is a bit vague in this regard, but it says "For non-document-based applications, use Application Name as the window title"ยน which refers to "name=" in the .desktop file.

The best "guideline" atm is comparing what the official control center modules do, e.g "Mouse" => "Mouse Preferences", "Appearance" => "Appearance Preferences"

If c) is misleading, why is the .desktop launcher called "Input Method"? :)

I just now noticed the "Input Method Preferences" button...

Problem is, I don't really understand what im-chooser does at all... you can activate general usage of input methods and then chose one in the list below? In that case, a radio widget would be helpful I think.

[1] http://library.gnome.org/devel/hig-book/nightly/windows-primary.html.en
Comment 3 Michael Monreal 2010-06-24 06:28:27 EDT
Thinking about it, it would fist make sense to think about if you plan to move im-chooser to a gnome3-style control center applet (like [1]) or if it will stay a standalone application and is really more like a "tool".

[1] http://www.0d.be/2010/06/24/vino-cc-panel/
Comment 4 Akira TAGOH 2010-06-24 06:37:32 EDT
(In reply to comment #2)
> If c) is misleading, why is the .desktop launcher called "Input Method"? :)

Because someone simply preferred simple one.

> Problem is, I don't really understand what im-chooser does at all... you can
> activate general usage of input methods and then chose one in the list below?

Right.

> In that case, a radio widget would be helpful I think.

Well, not really because it's likely to see more than 5 items there as GNOME HIG also adopt the case not using the radio button.
Comment 5 Akira TAGOH 2010-06-24 06:43:16 EDT
(In reply to comment #3)
> Thinking about it, it would fist make sense to think about if you plan to move
> im-chooser to a gnome3-style control center applet (like [1]) or if it will
> stay a standalone application and is really more like a "tool".
> 
> [1] http://www.0d.be/2010/06/24/vino-cc-panel/    

Aha. thanks for the info but this might be deprecated on GNOME 3 since we are thinking of the desktop integration more. however may want to stay a standalone for other desktops.
Comment 6 Akira TAGOH 2010-08-17 05:27:18 EDT
I'm still not sure what's the best way to fix this though, just committed the change to make the dialog resizable in upstream repo. FYI.
Comment 7 Akira TAGOH 2010-09-26 23:37:39 EDT
*** Bug 635955 has been marked as a duplicate of this bug. ***
Comment 8 Akira TAGOH 2010-10-20 04:10:04 EDT
Created attachment 454524 [details]
screenshot

one possible suggestion to make this improved. how does it look? also updating similarly for .desktop file.
Comment 9 Akira TAGOH 2010-11-15 02:13:52 EST
I'm going to make a new package with the above change though, any feedback for that?
Comment 10 Michael Monreal 2010-11-15 04:36:09 EST
I asked the UI people on IRC a number of times but never got a response :/

Anyway, the screenshot above includes a lower-case word in the window title which should be upper-case (window titles are all-uppercase)
Comment 11 Akira TAGOH 2010-11-15 08:38:20 EST
Sure. thanks for the comment. fixed it in the repo.
Comment 12 Akira TAGOH 2010-11-26 03:04:20 EST
fixed in im-choser-1.4.0-1.fc15. will backport the fix for f13 and f14.
Comment 13 Fedora Update System 2010-11-26 03:26:26 EST
im-chooser-1.4.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/im-chooser-1.4.0-1.fc14
Comment 14 Fedora Update System 2010-11-26 03:27:14 EST
im-chooser-1.4.0-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/im-chooser-1.4.0-1.fc13
Comment 15 Fedora Update System 2010-11-26 16:08:37 EST
im-chooser-1.4.0-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update im-chooser'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/im-chooser-1.4.0-1.fc14
Comment 16 Fedora Update System 2010-11-29 16:29:14 EST
im-chooser-1.4.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2010-12-07 15:15:24 EST
im-chooser-1.4.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.