Bug 607506 - [abrt] crash in imsettings-0.108.0-2.fc13: imsettings_monitor_add_file: Process /usr/libexec/im-settings-daemon was killed by signal 11 (SIGSEGV)
[abrt] crash in imsettings-0.108.0-2.fc13: imsettings_monitor_add_file: Proce...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: imsettings (Show other bugs)
6.0
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Akira TAGOH
QE Internationalization Bugs
abrt_hash:04a689180fbea4f036aaeac2197...
:
Depends On: 599924
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 05:38 EDT by Akira TAGOH
Modified: 2010-10-18 13:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: imsettings-0.108.0-3.3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 599924
Environment:
Last Closed: 2010-07-23 02:11:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-06-24 05:38:37 EDT
+++ This bug was initially created as a clone of Bug #599924 +++

abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/libexec/im-settings-daemon
component: imsettings
crash_function: imsettings_monitor_add_file
executable: /usr/libexec/im-settings-daemon
global_uuid: 04a689180fbea4f036aaeac21972d3bc7e3d0e98
kernel: 2.6.33.4-95.fc13.i686.PAE
package: imsettings-0.108.0-2.fc13
rating: 4
reason: Process /usr/libexec/im-settings-daemon was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

--- Additional comment from cpanceac@gmail.com on 2010-06-03 17:01:18 EDT ---

Created an attachment (id=420423)
File: backtrace

--- Additional comment from tagoh@redhat.com on 2010-06-03 21:47:26 EDT ---

can you upload $HOME/.imsettings.log as well?

--- Additional comment from cpanceac@gmail.com on 2010-06-03 23:19:46 EDT ---

Created an attachment (id=421107)
imsettings log

of course, here it is.

--- Additional comment from tagoh@redhat.com on 2010-06-24 05:36:33 EDT ---

Thanks. fixed in imsettings-0.108.0-4.fc13.
Comment 1 RHEL Product and Program Management 2010-06-24 05:53:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Akira TAGOH 2010-06-24 05:59:00 EDT
FYI, for the testcase on this issue:
http://code.google.com/p/imsettings/source/browse/trunk/tests/rhbz_599924.c
Comment 3 Akira TAGOH 2010-06-24 22:56:53 EDT
Fixed in imsettings-0.108.0-3.3.el6.
Comment 5 Kenichi Takemura 2010-07-13 23:40:26 EDT
Hi tagoh3

I am testing this bug

Can you give me a piece of advice how to use the test case(file) provided?
Comment 6 Akira TAGOH 2010-07-14 00:48:32 EDT
Easier way to run it is to check out the whole tree from the repo, building and run the test program. this test program reproduces the root cause indirectly.

Here is the step to build:
$ svn co http://imsettings.googlecode.com/svn/trunk imsettings
$ cd imsettings
$ ./autogen.sh --prefix=/usr --sysconfdir=/etc
$ make
$ cd tests
$ ./test-rhbz-599924

That may take a little time to finish and expecting no failures happens.
Hopes that help.
Comment 7 Kenichi Takemura 2010-07-14 21:28:56 EDT
Hi Tagoh3.

$ make results in errors.

Can you check for them?

main.c:31:25: error: gconf/gconf.h: No such file or directory
main.c:32:32: error: gconf/gconf-client.h: No such file or directory
In file included from main.c:33:
../../imsettings/imsettings-utils.h:28:23: error: dbus/dbus.h: No such file or directory
main.c:40: error: expected ‘)’ before ‘*’ token
main.c: In function ‘main’:
main.c:96: error: ‘GConfClient’ undeclared (first use in this function)
main.c:96: error: (Each undeclared identifier is reported only once
main.c:96: error: for each function it appears in.)
main.c:96: error: ‘client’ undeclared (first use in this function)
main.c:98: error: ‘GConfEntry’ undeclared (first use in this function)
main.c:98: error: ‘entry’ undeclared (first use in this function)
main.c:101: warning: implicit declaration of function ‘gconf_client_get_default’
main.c:106: warning: implicit declaration of function ‘gconf_client_add_dir’
main.c:107: error: ‘GCONF_CLIENT_PRELOAD_ONELEVEL’ undeclared (first use in this function)
main.c:113: warning: implicit declaration of function ‘gconf_client_notify_add’
main.c:114: error: ‘_notify_cb’ undeclared (first use in this function)
main.c:121: warning: implicit declaration of function ‘gconf_client_get_entry’
main.c:126: warning: implicit declaration of function ‘_notify_cb’
main.c:132: warning: implicit declaration of function ‘g_object_unref’
make[3]: *** [imsettings_lxde_helper-main.o] Error 1
make[3]: Leaving directory `/home/ktakemur/i18n/imsettings/backends/lxde'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/ktakemur/i18n/imsettings/backends'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ktakemur/i18n/imsettings'
make: *** [all] Error 2
Comment 8 Kenichi Takemura 2010-07-15 20:01:38 EDT
Hi Tagoh3

I was trying to reproduce this bug using the tool.
Can you say from the following log I could see the problem?

0%: Checks: 1, Failures: 0, Errors: 1
rhbz_599924.c:88:E:Bug#599924: https://bugzilla.redhat.com/show_bug.cgi?id=599924:test_issue:0: (after this point) Test timeout expired
Comment 9 Akira TAGOH 2010-07-15 21:50:04 EDT
Not really. that just means what it says. so the testing was incomplete. try to increase a number of tcase_set_timeout() in rhbz_599924.c
Comment 10 Kenichi Takemura 2010-07-20 23:19:57 EDT
I have been trying to verify this bug using the tool provided(pre complied by Tagoh3) and saw no errors under some high load average.
I can move this bug to VERIFIED.
Comment 11 Kenichi Takemura 2010-07-23 02:11:44 EDT

Closing this bug.

Verified on host build from rel-eng/RHEL6.0-20100715.2 tree

Verified version

# rpm -q imsettings
imsettings-0.108.0-3.3.el6.x86_64

Note You need to log in before you can comment on or make changes to this bug.