Bug 60762 - --lba32 option causes kickstart install to fail
--lba32 option causes kickstart install to fail
Status: CLOSED DUPLICATE of bug 53923
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-05 23:03 EST by G Sandine
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-06 01:01:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G Sandine 2002-03-05 23:03:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.18 i686)

Description of problem:
The command

bootloader --location=mbr --useLilo --lba32

in a kickstart file causes the installation to terminate,
with the error message ending in:

    [ 'append=', 'location=', 'useLilo', '--lba32',
  File "/usr/llib/anaconda/isys.py", line 301, in getopt
    return apply(_isys.getopt, args)
TypeError: bad argument --lba32: unknown option


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Put the above bootloader line in ones ks.cfg

	

Actual Results:  Install fails.

Expected Results:  Install should not fail because of that bootloader command,
per the RH 7.2 ``Kickstart Options'' documentation.

Additional info:

We Google for this and find a suggestion to include

--nolinear

with the above listed arguments to bootloader, but this fails
identically.  We have tried reordering the arguments various
ways but all result in identical failure.

Turns out, one can do

bootloader --location=mbr --useLilo lba32

and the lba32 option passes correctly and install succeeds.
Evidently, the ``--'' do not get stripped prior to lba32 option.
Comment 1 G Sandine 2002-03-06 01:01:09 EST
Using

bootloader --location=mbr --useLilo lba32

does get one through a kickstart installation but the default ``linear''
appears in /etc/lilo.conf.
Comment 2 Jeremy Katz 2002-03-06 11:04:26 EST
Fixed in the anaconda update disk released the middle of last month

*** This bug has been marked as a duplicate of 53923 ***
Comment 3 Bharathi S 2004-12-17 06:07:19 EST
bootloader --location=mbr --useLilo lba32

The above option will not help you to solve this problem. We can add 
the lba32 option in the Post Install script. Like this

%post

echo "lba32" > /tmp/lilo.conf
grep -v "linear"  /etc/lilo.conf >> /tmp/lilo.conf
mv /tmp/lilo.conf /etc/lilo.conf

/sbin/lilo

# Remaining post install task :)

Note You need to log in before you can comment on or make changes to this bug.