Bug 607664 - AttributeError: 'AnacondaYumRepo' object has no attribute 'excludepkgs'
AttributeError: 'AnacondaYumRepo' object has no attribute 'excludepkgs'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Brian Lane
Martin Banas
anaconda_trace_hash:1fad0e2b3a4ff3a6d...
: TestBlocker
: 609246 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 10:32 EDT by Alexander Todorov
Modified: 2010-11-10 14:49 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-13.21.55-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:49:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (231.28 KB, text/plain)
2010-06-24 10:32 EDT, Alexander Todorov
no flags Details
Attached traceback automatically from anaconda. (1.38 MB, text/plain)
2010-06-29 04:45 EDT, Martin Banas
no flags Details
Attached traceback automatically from anaconda. (261.52 KB, text/plain)
2010-07-01 04:28 EDT, CAI Qian
no flags Details
Attached traceback automatically from anaconda. (420.71 KB, text/plain)
2010-07-01 05:28 EDT, CAI Qian
no flags Details

  None (edit)
Description Alexander Todorov 2010-06-24 10:32:03 EDT
The following was filed automatically by anaconda:
anaconda 13.21.50 exception report
Traceback (most recent call first):
  File "/tmp/updates/yuminstall.py", line 1943, in writeKS
    if repo.excludepkgs:
  File "/usr/lib/anaconda/instdata.py", line 276, in writeKS
    self.backend.writeKS(f)
  File "/usr/lib/anaconda/packages.py", line 66, in writeKSConfiguration
    anaconda.id.writeKS(fn)
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1335, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1356, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'AnacondaYumRepo' object has no attribute 'excludepkgs'
Comment 1 Alexander Todorov 2010-06-24 10:32:07 EDT
Created attachment 426596 [details]
Attached traceback automatically from anaconda.
Comment 2 Alexander Todorov 2010-06-24 10:34:09 EDT
This is with 0622.1 tree and updates.img from:
https://bugzilla.redhat.com/show_bug.cgi?id=602705#c2

I was testing bug 602705.
Comment 3 RHEL Product and Program Management 2010-06-24 10:52:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Martin Banas 2010-06-29 04:45:59 EDT
Created attachment 427611 [details]
Attached traceback automatically from anaconda.
Comment 5 Martin Banas 2010-06-29 09:53:06 EDT
Adding blocker flag since we need this to be fixed in Snapshot 7.
Comment 6 Chris Lumens 2010-06-29 14:26:37 EDT
*** Bug 609246 has been marked as a duplicate of this bug. ***
Comment 7 CAI Qian 2010-07-01 04:28:03 EDT
Created attachment 428205 [details]
Attached traceback automatically from anaconda.
Comment 8 CAI Qian 2010-07-01 05:28:07 EDT
Created attachment 428217 [details]
Attached traceback automatically from anaconda.
Comment 10 Martin Banas 2010-07-02 02:49:50 EDT
This doesn't happen anymore with build RHEL6.0-20100701.0, anaconda-13.21.56-1.el6.
Closing as VERIFIED.
Comment 11 releng-rhel@redhat.com 2010-11-10 14:49:07 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.