Bug 609246 - Cannot create a Xen RHEL6 x86 PV guest.
Cannot create a Xen RHEL6 x86 PV guest.
Status: CLOSED DUPLICATE of bug 607664
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 14:20 EDT by Dave Anderson
Modified: 2010-06-29 14:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 14:26:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-tb-jldPrQ8bYeA8.xml (207.46 KB, text/xml)
2010-06-29 14:20 EDT, Dave Anderson
no flags Details

  None (edit)
Description Dave Anderson 2010-06-29 14:20:22 EDT
Created attachment 427757 [details]
anaconda-tb-jldPrQ8bYeA8.xml

Description of problem:

While an x86_64 RHEL6 PV Xen guest can be created with virt-manager,
all attempts to do so with an x86 RHEL6 x86 PV guest fail.  
Presumably this could be a virt-manager or virt-install issue,
but they both seemt to work fine, but when anaconda runs, it
causes the console screen to "go black" if virt-manager is used, or
causes an anaconda exception if the virt-install CLI is used.  
The anaconda exception xml is attached, but has this message
at the top:

The following was filed automatically by anaconda:
anaconda 13.21.54 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 1946, in writeKS
    if repo.excludepkgs:
  File "/usr/lib/anaconda/instdata.py", line 276, in writeKS
    self.backend.writeKS(f)
  File "/usr/lib/anaconda/packages.py", line 66, in writeKSConfiguration
    anaconda.id.writeKS(fn)
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 657, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1106, in <module>
    anaconda.intf.run(anaconda)
AttributeError: 'AnacondaYumRepo' object has no attribute 'excludepkgs'
 

Version-Release number of selected component (if applicable):

host: x86_64 running 2.6.18-194.el5xen 
guest: x86 x86 2.6.32-37.el6 (attempted)

How reproducible:

With virt-manager, anaconda doesn't start (screen goes black)
With virt-install, anaconda exception (xml file attached)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2010-06-29 14:26:37 EDT

*** This bug has been marked as a duplicate of bug 607664 ***

Note You need to log in before you can comment on or make changes to this bug.