Bug 607718 - mono server does not allow connections
mono server does not allow connections
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mod_mono (Show other bugs)
13
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 12:11 EDT by ea6825
Modified: 2010-09-01 01:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: mod_mono-2.6.3-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-31 23:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mod_mono-2.6.3_configure.log (7.50 KB, application/octet-stream)
2010-08-14 13:49 EDT, Herbert
no flags Details

  None (edit)
Description ea6825 2010-06-24 12:11:20 EDT
Description of problem:  After upgrade to FC13 Mono server does not work.


Version-Release number of selected component (if applicable: Mono JIT 2.6.1


How reproducible: Browse to an ASP.NET web application on the Apache host.


Steps to Reproduce:
1. same as above
2.
3.
  
Actual results: "Service Temporarily Unavailable" websever reply


Expected results:  The appropriate application web page requsted
 

Additional info:  The httpd error log says "Failed to connect to mod-mono-server after several attempts to spawn process."  Additional note...this situation occurs as as result of upgrading from fc12 to fc13. The FC12 configurations worked just fine.
Comment 1 Herbert 2010-08-12 16:19:58 EDT
Had the same problem after upgrading from FC11 to FC13.

After downloading mod_mono-2.6.3.tar.bz2 I did the following (which resolved the problem):

tar -jxvf mod_mono-2.6.3.tar.bz2
cd mod_mono-2.6.3
./configure --prefix=/usr
make
make install

Note: Had to install httpd-devel first.
Comment 2 Christian Krause 2010-08-13 10:34:51 EDT
mod_mono-2.6.3 was pushed to F-13 stable a month ago:

https://admin.fedoraproject.org/updates/gnome-sharp-2.24.1-1.fc13,gtksourceview-sharp-2.0.12-11.fc13,mono-tools-2.6.2-1.fc13,mod_mono-2.6.3-1.fc13,xsp-2.6.4-1.fc13,mono-2.6.4-1.fc13,mono-basic-2.6.2-1.fc13,libgdiplus-2.6.4-1.fc13

Please can you try, whether the problem is still present in a fully updated system?

If yes, please verify with "rpm -q mod_mono" which mod_mono version is installed and provide exact steps how the problem can be reprocued.
Comment 3 Herbert 2010-08-13 11:14:53 EDT
Christian, I checked the versions of your mentioned packages and they match, especially mod_mono is reported to be mod_mono-2.6.3-1.fc13.i686.

Because mod_mono-2.6.3-1.fc13.i686 was NOT working out of the box, I had to what I reported already.
Comment 4 Christian Krause 2010-08-14 10:36:16 EDT
(In reply to comment #3)
> Because mod_mono-2.6.3-1.fc13.i686 was NOT working out of the box, I had to
> what I reported already.

Ok, I'll check what could influence the build.

Please provide the following information:

1. run
./configure --prefix=/usr &>/tmp/configure.log
and attach the generated /tmp/configure.log to this bug report

2. please provide the exact steps how I can fully reproduce the problem
Comment 5 Christian Krause 2010-08-14 13:36:14 EDT
I found the problem. One Fedora-specific patch caused the issue. I'll provide new packages for rawhide, F14 and F13 soon. The patch in F12 is correct, so no need for action there.
Comment 6 Herbert 2010-08-14 13:49:32 EDT
Created attachment 438797 [details]
mod_mono-2.6.3_configure.log
Comment 7 Herbert 2010-08-14 14:03:04 EDT
1) Attached the ./configure.log as instructed.

2) Upgrade procedure:
- Had a running FC11 system and, because of announced end of support, I decided to risk an upgrade to FC13.
- For that purpose I downloaded the iso image for the FC13 installation DVD and burned a DVD.
- I booted from DVD and followed the 'upgrade' instructions and the upgrade finished without any problems.
- Updated the new system (> 650 updates, ~ 950 MB). Remark: Would have been nice to have a more recent iso image with updates incorporated. ;-)
- After starting the httpd service I found out, that mono applications were not working.
- Googling for a solution was not successful - I had to delve into mod_mono by myself. :-(
- To find more information I downloaded the sources of mod_mono and after installing the new mod_mono, the problem vanished.
Comment 8 Fedora Update System 2010-08-14 14:53:23 EDT
mod_mono-2.6.3-3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/mod_mono-2.6.3-3.fc14
Comment 9 Fedora Update System 2010-08-14 14:54:07 EDT
mod_mono-2.6.3-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mod_mono-2.6.3-2.fc13
Comment 10 Fedora Update System 2010-08-16 12:03:37 EDT
mod_mono-2.6.3-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mod_mono'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mod_mono-2.6.3-3.fc14
Comment 11 ea6825 2010-08-16 19:38:31 EDT
I have installed the 'build rpm' that was submitted for testing to address the FC13 defect and I am now able to successfully run an ASP.NET application on my Apache server via mod_mono. Now that FC13 can run my necessary applications I can retire my remaining FC12 implementations and anticipate FC14.  hurray!
Comment 12 Fedora Update System 2010-08-31 23:29:25 EDT
mod_mono-2.6.3-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-09-01 01:53:15 EDT
mod_mono-2.6.3-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.