Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 607781 - kdebase includes empty /usr/lib/mozilla, may trump xulrunner dependency resolution
kdebase includes empty /usr/lib/mozilla, may trump xulrunner dependency resol...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdebase (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 15:13 EDT by Bryan J Smith
Modified: 2014-09-14 20:11 EDT (History)
5 users (show)

See Also:
Fixed In Version: kdebase-6:3.5.4-25.el5
Doc Type: Bug Fix
Doc Text:
Prior to this update, the kdebase package included the empty directories /usr/lib/mozilla/ and /usr/lib/mozilla/plugins/. This update corrects the problem so that the kdebase package does not include these empty directories anymore.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-07 09:18:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1277 normal SHIPPED_LIVE kdebase bug fix update 2011-09-07 09:18:16 EDT

  None (edit)
Description Bryan J Smith 2010-06-24 15:13:16 EDT
Description of problem:

The package kdebase includes the following, empty directories:  
  /usr/lib/mozilla
  /usr/lib/mozilla/plugins

RHEL 5.2 and later, which include separate packages of firefox and xulrunner, the first may cause a dependency resolution issue.  If firefox is not installed, or firefox 1.5.0.x (pre-5.2) is installed, attempting to install firefox may install kdebase as a dependency, instead of, or in addition to, xulrunner.

There may be other combinations of packages and resolutions that may cause this issue as well.

Version-Release number of selected component (if applicable):

RHEL 5.2+ (possibly RHEL 4.7+ as well)

How reproducible:

Limited, but possible.  Depends on combinations of packages installed.

Steps to Reproduce:
1.  Install RHEL 5.0 or 5.1 system with firefox, or RHEL 5.x with no firefox
2.  yum upgrade firefox
3.

[WORKAROUND]  Install package "xulrunner" first
  
Actual results:

Sometimes similar to ...

... cut ...
Skipping security plugin, no data
--> Running transaction check
---> Package firefox.i386 0:3.6.4-8.el5 set to be updated
--> Processing Dependency: xulrunner >= 1.9.2.4-8 for package: firefox
--> Running transaction check
--> Processing Dependency: xulrunner = 1.9.0.19-1.el5_5 for package: 
xulrunner-devel
--> Processing Dependency: xulrunner = 1.9.0.19-1.el5_5 for package: 
xulrunner-devel
---> Package xulrunner.i386 0:1.9.2.4-9.el5 set to be updated
---> Package xulrunner.x86_64 0:1.9.2.4-9.el5 set to be updated
--> Running transaction check
---> Package xulrunner-devel.i386 0:1.9.2.4-9.el5 set to be updated
--> Processing Dependency: libnotify-devel for package: xulrunner-devel
---> Package xulrunner-devel.x86_64 0:1.9.2.4-9.el5 set to be updated
--> Running transaction check
---> Package libnotify-devel.x86_64 0:0.4.2-6.el5 set to be updated
epel/filelists_db                                        | 4.3 MB 
00:01
rhel-x86_64-server-5/filelists                           |  23 MB 
00:02
rhel-x86_64-server-supplementary-5/filelists             | 1.9 MB 
00:00
--> Processing Dependency: /usr/lib/mozilla/plugins for package: 
java-1.6.0-ibm-plugin
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package kdebase.i386 6:3.5.4-21.el5_5.1 set to be updated
--> Processing Dependency: kdelibs >= 6:3.5.4-16 for package: kdebase
... cut ...
(and lots and lots of KDE stuff)

Expected results:

Only xulrunner[-devel] above.

Additional info:

I do not see a reason for this:  

  $ rpm -qf /usr/lib/mozilla
  kdebase-3.5.4-20.el5
  xulrunner-1.9.0.16-2.el5_4

At most, only this (plug-in directory, like nspluginwrapper, RealPlayer, etc...):  

  $ rpm -qf /usr/lib/mozilla/plugins
  RealPlayer-10.0.9-3.el5
  nspluginwrapper-0.9.91.5-22.el5
  kdebase-3.5.4-20.el5
  xulrunner-1.9.0.16-2.el5_4

I.e., if KDE's KTHML/konqueror expects /usr/lib/mozilla/plugins to exist, or provides something.  But I don't see a reason for /usr/lib/mozilla to be provided by Konqueror.
Comment 1 Bryan J Smith 2010-06-24 15:22:06 EDT
Actually, java-1.[56].0-sun-plugin has a requirement on /usr/lib/mozilla/plugins as well, which could bring in kdebase (or nspluginwrapper), etc...
Comment 2 Bryan J Smith 2010-06-24 15:35:52 EDT
And xulrunner 1.9.2 no longer provides /usr/lib/mozilla
Comment 3 Bryan J Smith 2010-06-24 15:53:37 EDT
I originally made this "low" priority because I thought there was a workaround.  The workaround of installing xulrunner first won't work as a result of xulrunner 1.9.2 not including /usr/lib[64]/mozilla.

Here is the xulrunner Bugzilla:  
  https://bugzilla.redhat.com/show_bug.cgi?id=607788  

I still think this should still be revisited.  But it appears it requires another package with a dependency on /usr/lib[64]/mozilla[/plugins], and not firefox itself, to cause this.
Comment 4 Bryan J Smith 2010-06-24 16:33:58 EDT
As noted in https://bugzilla.redhat.com/show_bug.cgi?id=607681#c5  

"Since XULRunner is separate from Firefox, this would be a better move, especially since XULRunner is a 11MB download versus ... say ... something like KDE."

My View:  Packages checking for /usr/lib/mozilla[/plugins] as the dependency
for a web browser is bad behavior and unreliable, and should not be rewarded.  The "cost" of rewarding KDE versus anything like XULRunner should be the final consideration in this matter, at least that is my view.
Comment 14 Petr Kovar 2011-09-06 10:37:20 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, the kdebase package included the empty directories /usr/lib/mozilla/ and /usr/lib/mozilla/plugins/. This update corrects the problem so that the kdebase package does not include these empty directories anymore.
Comment 15 errata-xmlrpc 2011-09-07 09:18:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1277.html

Note You need to log in before you can comment on or make changes to this bug.