Bug 607864 - Screen turns blank during install of F13 on core i5 with Intel GMA HD graphics
Screen turns blank during install of F13 on core i5 with Intel GMA HD graphics
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
14
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 23:12 EDT by Johannes Goller
Modified: 2018-04-11 03:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-30 01:43:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log from 2.6.32.14 Kernel F12 (20.06 KB, text/plain)
2010-06-28 04:51 EDT, Johannes Goller
no flags Details
dmesg output from 2.6.32.14 Kernel F12 (43.70 KB, text/plain)
2010-06-28 04:52 EDT, Johannes Goller
no flags Details
/var/log/anaconda.log from 2.6.32.14 Kernel F12 (69.46 KB, text/plain)
2010-06-28 04:53 EDT, Johannes Goller
no flags Details

  None (edit)
Description Johannes Goller 2010-06-24 23:12:15 EDT
Description of problem:
When installing F13 from the live CD, the screen turns black instead of switching to graphics mode.
Note the following difference from Bug 570538:

(1) This cannot be worked around using the vesa driver in the kernel options: If I add "xdriver=vesa nomodeset" to the options, a blue and growing status bar is displayed at the lower end of the screen, but once it reaches 100% the screen still turns black and does not recover.

(2) The option "video=LVDS-1:e", as described in Bug 570538 does not change anything.

These problems do not occur when F11 is used to install (I haven't tried with F12).

Version-Release number of selected component (if applicable):
Fedora-13-i686-Live-KDE

How reproducible:
100%

Steps to Reproduce:
1. Boot from the F13 live CD (KDE version)
2.
3.
  
Actual results:
Screen turns black as soon as installer goes to graphics mode

Expected results:
Completion of installation with proper graphical display.
Comment 1 Matěj Cepl 2010-06-25 19:11:55 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information especially concerning your hardware we require that will be helpful in our diagnosis of this issue.

If the anaconda crashes during the switching to the graphic mode, most likely the problem lies in Xorg support for your graphics chip. There are couple of options how we can obtain information necessary for resolving the issue.

If the computer is not completely frozen when installation fails, switch to the console (Ctrl+Alt+F2) and copy /tmp/X* and /var/log/anaconda.xlog to some other place -- USB stick, some other computer via network, somewhere on the Internet, and please attach it to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

If the computer is completely useless after installation fails, you can also install Fedora with a VESA mode driver (see http://docs.fedoraproject.org/en-US/Fedora/13/html/Installation_Guide/
for more information on that). Then after successful installation you can collect /var/log/anaconda.xlog, /var/log/Xorg.0.log, and the output of the program dmesg instead.

Or you can install Fedora in a text mode completely, and then start X after that. If it fails, still /var/log/Xorg.0.log and the output of dmesg program from the failed attempt to start X would be useful.

We will review this issue again once you've had a chance to attach this information.

Thank you very much in advance.
Comment 2 Johannes Goller 2010-06-28 04:51:50 EDT
Created attachment 427351 [details]
/var/log/Xorg.0.log from 2.6.32.14 Kernel F12
Comment 3 Johannes Goller 2010-06-28 04:52:39 EDT
Created attachment 427352 [details]
dmesg output from 2.6.32.14 Kernel F12
Comment 4 Johannes Goller 2010-06-28 04:53:08 EDT
Created attachment 427353 [details]
/var/log/anaconda.log from 2.6.32.14 Kernel F12
Comment 5 Johannes Goller 2010-06-28 04:54:10 EDT
Thank you for your quick reaction.

Unforunately, I wasn't able to to extract the logs from the failed installation attempts. Although the system is not entirely frozen after it switches into graphical mode (e.g. the sound when it apparently arrives at the Live environment can be heard), I am unable to switch it to text mode or do anything useful at all.

Note that this is also true when I use the vesa driver (i.e. I add "xdriver=vesa nomodeset" to the Kernel options, is that what you meant?). This causes a progress bar to be displayed (but still in text mode) while the Live environment prepares itself, but when it finally switches into graphics mode, still nothing comes up, and not even sound can be heard then.

However, I managed something else meanwhile: It turns out that installing F12 is possible and it comes up fine on a 2.6.31.5 kernel. When I then do "yum update", I get hundreds of packages updated, among them the kernel (it becomes 2.6.32.14). After that update, the system fails again as soon as it switches to graphics, but this time it is still reactive.
I can switch it to a text konsole and it performs the commands I enter, although it still does not display anything (not even in the text console).

Blindly extracting the logs you asked for gave the files I am attaching now. So these are the logs after running the 2.6.32.14 kernel from an F12 installation.

The anaconda.xlog does not seem to exist (it does not exist in the healthy 2.6.31.5 kernel either). I am attaching anaconda.log instead, in case it helps.
Comment 6 Johannes Goller 2010-07-05 03:28:21 EDT
Today I received an email from someone from intel.com you says the problem I described here had already been fixed:

https://bugs.freedesktop.org/show_bug.cgi?id=28070#c47

This fix is apparently already available from recent versions of the kernel, although I personally don't understand which version that is and whether and when it will become available as a yum upgrade for Fedora.

Perhaps needless to say that I would be grateful if such an upgrade became available, both for F12 and F13.
Comment 7 Johannes Goller 2010-07-07 04:43:38 EDT
I built my own kernel for F12, using the patch mentioned above, specifically these two patches:

http://lists.freedesktop.org/archives/intel-gfx/2010-June/007216.html
http://lists.freedesktop.org/archives/intel-gfx/2010-June/007232.html

The new kernel was based on the latest for F12, i.e. 2.6.32.14-127.fc12. With the fixed kernel, graphics works without flaws, even dual head is possible.

I haven't tried yet, but I guess the same patch will work with F13 too.
Comment 8 Gendre Sébastien 2010-11-06 17:15:02 EDT
I have the same problème on Fedora 13 and Fedora 14 on a HP DM4 with Intel® Core™ i5-460M.

Precisely, the screen don't turn blank. LCD keeps ON, this is the backlight that be in minimum (OFF).

If I turn off ACPI control, the screen don't turns blank.
Comment 9 Johannes Goller 2011-06-15 01:33:23 EDT
These problems have been solved in F15 it seems. But there is a new problem: Bug #709091.

Note You need to log in before you can comment on or make changes to this bug.