Bug 607865 - [abrt] crash in wicd-gtk-1.7.0-1.fc13: wicd-client.py:724:_trigger_scan_if_needed:AttributeError: 'NoneType' object has no attribute 'Scan'
Summary: [abrt] crash in wicd-gtk-1.7.0-1.fc13: wicd-client.py:724:_trigger_scan_if_ne...
Status: CLOSED DUPLICATE of bug 611104
Alias: None
Product: Fedora
Classification: Fedora
Component: wicd (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:fea898b2
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-25 03:22 UTC by dtdraganov
Modified: 2010-08-20 01:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 01:37:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (590 bytes, text/plain)
2010-06-25 03:22 UTC, dtdraganov
no flags Details

Description dtdraganov 2010-06-25 03:22:29 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python -O /usr/share/wicd/gtk/wicd-client.py
component: wicd
executable: /usr/share/wicd/gtk/wicd-client.py
kernel: 2.6.33.5-124.fc13.x86_64
package: wicd-gtk-1.7.0-1.fc13
reason: wicd-client.py:724:_trigger_scan_if_needed:AttributeError: 'NoneType' object has no attribute 'Scan'
release: Fedora release 13 (Goddard)

backtrace
-----
wicd-client.py:724:_trigger_scan_if_needed:AttributeError: 'NoneType' object has no attribute 'Scan'

Traceback (most recent call last):
  File "/usr/share/wicd/gtk/wicd-client.py", line 90, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/wicd/gtk/wicd-client.py", line 724, in _trigger_scan_if_needed
    wireless.Scan(False)
AttributeError: 'NoneType' object has no attribute 'Scan'

Local variables in innermost frame:
item: <gtk.ImageMenuItem object at 0x146df00 (GtkImageMenuItem at 0x11fc9f0)>
self: <StatusTrayIconGUI object at 0x146d3c0 (GtkStatusIcon at 0x132a640)>

Comment 1 dtdraganov 2010-06-25 03:22:32 UTC
Created attachment 426755 [details]
File: backtrace

Comment 2 Ted 2010-07-01 02:05:26 UTC
Package: wicd-gtk-1.7.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
I just installed wicd, running on kde. The next startup, I used gnome. There was a message saying the daemon shut down. I clicked the icon and hovered over the network list.

Comment 3 David Cantrell 2010-07-13 01:05:36 UTC
How did you install and enable wicd?  Did you disable and/or remove NetworkManager?

Comment 4 Ted 2010-07-13 22:52:17 UTC
I believe I used yum on the command line. I left networkmanager and didn't stop the service. I think an error message shows up, saying that it couldn't connect to wicd using dbus, the interface will not function.

Comment 5 Onalenna Junior Makhura 2010-08-05 13:33:27 UTC
Package: wicd-gtk-1.7.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.I updated wicd
2.I then rebooted and could not connect 
3.

Comment 6 Leif H. 2010-08-07 20:15:26 UTC
Package: wicd-gtk-1.7.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
bug appears at start up, after login

Comment 7 David Cantrell 2010-08-20 01:37:35 UTC

*** This bug has been marked as a duplicate of bug 611104 ***


Note You need to log in before you can comment on or make changes to this bug.