Bug 611104 - [abrt] crash in wicd-gtk-1.7.0-1.fc13: gui.py:154:__init__:AttributeError: 'NoneType' object has no attribute 'ReadWindowSize'
[abrt] crash in wicd-gtk-1.7.0-1.fc13: gui.py:154:__init__:AttributeError: 'N...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wicd (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:7cc26af9
:
: 607702 607865 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-03 13:30 EDT by Vinayak Kumbhakern
Modified: 2010-08-19 21:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 713109 (view as bug list)
Environment:
Last Closed: 2010-07-15 09:50:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (730 bytes, text/plain)
2010-07-03 13:30 EDT, Vinayak Kumbhakern
no flags Details

  None (edit)
Description Vinayak Kumbhakern 2010-07-03 13:30:42 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python -O /usr/share/wicd/gtk/wicd-client.py --no-tray
component: wicd
executable: /usr/share/wicd/gtk/wicd-client.py
kernel: 2.6.33.5-124.fc13.i686
package: wicd-gtk-1.7.0-1.fc13
reason: gui.py:154:__init__:AttributeError: 'NoneType' object has no attribute 'ReadWindowSize'
release: Fedora release 13 (Goddard)

backtrace
-----
gui.py:154:__init__:AttributeError: 'NoneType' object has no attribute 'ReadWindowSize'

Traceback (most recent call last):
  File "/usr/share/wicd/gtk/wicd-client.py", line 1032, in <module>
    main(sys.argv)
  File "/usr/share/wicd/gtk/wicd-client.py", line 90, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/wicd/gtk/wicd-client.py", line 998, in main
    the_gui = gui.appGui(standalone=True)
  File "/usr/share/wicd/gtk/gui.py", line 154, in __init__
    size = daemon.ReadWindowSize("main")
AttributeError: 'NoneType' object has no attribute 'ReadWindowSize'

Local variables in innermost frame:
tray: None
self: <gui.appGui object at 0x8b37fec>
gladefile: '/usr/share/wicd/gtk/wicd.glade'
standalone: True
Comment 1 Vinayak Kumbhakern 2010-07-03 13:30:45 EDT
Created attachment 429279 [details]
File: backtrace
Comment 2 laurelai 2010-07-09 15:48:16 EDT
Package: wicd-gtk-1.7.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. installed wicd
2. installed wicd-gtk
3. started wicd
Comment 3 Donald Harper 2010-07-14 23:02:15 EDT
Package: wicd-gtk-1.7.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Install Fedora13 from Summit 2010 live USB
2. yum upgrade -y
3. reboot
4. yum install wicd\* -y
5. run wicd-gtk
Comment 4 David Cantrell 2010-07-15 09:50:20 EDT
To use wicd, you need to uninstall or disable NetworkManager.  After installing wicd packages, make sure you do:

    service NetworkManager stop
    chkconfig NetworkManager off
    chkconfig wicd on
    service wicd start
Comment 5 Donald Harper 2010-07-15 22:01:40 EDT
If this is a know issue, why does wicd and NetworkManager have a Conflict line in the SPEC file?
Comment 6 David Cantrell 2010-07-16 14:46:12 EDT
I wanted to add a Conflict line, but the package reviewers disagreed.  Technically, the packages can be installed at the same time, so there's not really a conflict.  You can only run one or the other.
Comment 7 David Cantrell 2010-08-19 21:36:57 EDT
*** Bug 607702 has been marked as a duplicate of this bug. ***
Comment 8 David Cantrell 2010-08-19 21:37:35 EDT
*** Bug 607865 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.