Bug 60798 - PPTP Client
Summary: PPTP Client
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
: 68853 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-06 21:30 UTC by Ralf Baechle
Modified: 2007-04-18 16:40 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-18 15:53:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Baechle 2002-03-06 21:30:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Using PPTP for VPN networking to access corporate intranets seems
to be becoming popular.  I got this working here but it's rather
intrusive as it requires modifications to both the kernel (new mppe
module and modified ppp_generic module) and the pppd package.

Yes, I know PPTP sucks by design but it turned into a must-have for
me ...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.(Having to fill the reproduce field for a feature request is silly)
2.
3.
	

Additional info:

Comment 1 Arjan van de Ven 2002-03-19 18:35:22 UTC
It seems that most if not all pptp clients use non-gpl compatible code in the
kernel bits ;(

Comment 2 Michael K. Johnson 2003-02-19 15:03:29 UTC
*** Bug 68853 has been marked as a duplicate of this bug. ***

Comment 3 Matt Selsky 2003-02-19 15:31:21 UTC
The comments in the MPPE kernel patches available at
http://prdownloads.sourceforge.net/pptpclient/ppp-2.4.2_cvs_20021120.tar.gz seem
to indicate that the sha1 and arcfour code they have is public domain. 
According to http://www.gnu.org/philosophy/license-list.html public domain
licensing is compatible with the GPL.

Comment 4 Dr. Peter Boy 2003-07-28 09:17:39 UTC
May I "reactivate" this request for the current severn beta? pptp is widely
used, despite its deficiencies, the GPL issue seems to be solved, and the
current RH9 version on pptpclient.sourceforge.net is solid and well done.

In a further step redhat-configuration/control-network should include
adtivation/deactivation of pptp (just as cipe)

Peter Boy

Comment 5 Dave Jones 2003-11-18 15:53:35 UTC
If the license issues are resolved, the pptp folks need to get their
stuff pushed upstream.
If its not good enough for upstream, it's not good enough for FC / RHEL.
Aparently, there have been requests for them to do this in the past,
which have fallen on deaf ears.



Note You need to log in before you can comment on or make changes to this bug.