Bug 608016 - Typo in unsupported-character-set error message
Typo in unsupported-character-set error message
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Tim Waugh
qe-baseos-daemons
: EasyFix
: 662705 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 08:12 EDT by Tim Waugh
Modified: 2011-01-13 18:29 EST (History)
5 users (show)

See Also:
Fixed In Version: cups-1.3.7-24.el5
Doc Type: Bug Fix
Doc Text:
The unsupported-character-set error message used the formatting: "Unsupported character set [host.name] from host [character.set]! Clients must use us-ascii or utf-8." This was due to a mistake in the error message formatting. With this update, the parameters are swapped and the error message uses the correct parameter order.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 18:29:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2010-06-25 08:12:09 EDT
Description of problem:
The arguments to the unsupported-character-set message are swapped, so that it looks like:

Unsupported character set \"host.name\" from host iso-8859-1! Clients must use us-ascii or utf-8.  Future versions will reject this request.

It's trivial to swap the parameters round.

Version-Release number of selected component (if applicable):
cups-1.3.7-22.el5
Comment 4 Tim Waugh 2010-09-23 12:25:14 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When a client uses an unsupported character set, an error message is logged.  A mistake in the error message formatting caused some words to be swapped around.  The formatting has now been fixed.
Comment 6 Eva Kopalova 2010-11-19 05:04:38 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-When a client uses an unsupported character set, an error message is logged.  A mistake in the error message formatting caused some words to be swapped around.  The formatting has now been fixed.+The unsupported-character-set error message used the formatting: "Unsupported character set [host.name] from host [character.set]! Clients must use us-ascii or utf-8." This was due to a mistake in the error message formatting. With this update, the parameters are swapped and the error message uses the correct parameter order.
Comment 8 Tim Waugh 2010-12-14 07:47:13 EST
*** Bug 662705 has been marked as a duplicate of this bug. ***
Comment 10 errata-xmlrpc 2011-01-13 18:29:43 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0095.html

Note You need to log in before you can comment on or make changes to this bug.