Bug 662705 - Warning Unsupported character set "localhost" from host iso-8859-1
Summary: Warning Unsupported character set "localhost" from host iso-8859-1
Keywords:
Status: CLOSED DUPLICATE of bug 608016
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups
Version: 5.5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-13 16:33 UTC by Sergey Smirnov
Modified: 2013-03-20 05:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-14 12:47:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sergey Smirnov 2010-12-13 16:33:37 UTC
Description of problem:
There are number if warnings in /var/log/cups/error_log:
E [09/Dec/2010:04:02:09 +0300] Unsupported character set "localhost" from host iso-8859-1! Clients must use us-ascii or utf-8.  Future versions will reject this request.
E [09/Dec/2010:04:02:10 +0300] Unsupported character set "localhost" from host iso-8859-1! Clients must use us-ascii or utf-8.  Future versions will reject this request.
E [09/Dec/2010:04:02:14 +0300] Unsupported character set "localhost" from host iso-8859-1! Clients must use us-ascii or utf-8.  Future versions will reject this request.

Version-Release number of selected component (if applicable):
kernel 2.6.18-194.26.1.el5

How reproducible:
Always

Steps to Reproduce:
1. Add new printer with command: lpadmin -p tally30 -i /etc/lp/interfaces/model.orig/tally30 -E -v socket://29.3.2.58 -o printer-error-policy=retry-job
2. Print with command: cat file | lp -d printername
3. Get warning
  
Actual results:
Warnings in /var/log/cups/error_log

Expected results:
No warnings

Additional info:

Same time in /var/log/cups/access_log:
localhost - - [09/Dec/2010:04:02:09 +0300] "POST / HTTP/1.1" 200 134 CUPS-Get-Printers successful-ok
localhost - - [09/Dec/2010:04:02:10 +0300] "POST / HTTP/1.1" 200 134 CUPS-Get-Classes successful-ok
localhost - - [09/Dec/2010:04:02:14 +0300] "POST / HTTP/1.1" 200 134 CUPS-Get-Printers successful-ok

System encoding settings /etc/i18n:
#LANG=en_US
LANG=ru_RU.cp866
SYSFONT=Cyr_a8x16
ACMTABLE=cp866
KEYTABLE=ru2

Comment 1 Tim Waugh 2010-12-13 17:00:46 UTC
Is the problem the switched-around arguments in the string ("localhost" and "iso-8859-1"), or the fact that the warning message occurs at all?

The first is being tracked in bug #608016; the second is intentional behaviour but perhaps ought to be rate-limited to once per client per boot or just once per boot.

Comment 2 Sergey Smirnov 2010-12-14 09:54:46 UTC
Thanx Tim, the first one should be ok for customer, case can be closed.

Comment 3 Tim Waugh 2010-12-14 12:47:13 UTC

*** This bug has been marked as a duplicate of bug 608016 ***


Note You need to log in before you can comment on or make changes to this bug.