Bug 608037 - [abrt] crash in epiphany-2.30.2-1.fc13: malloc_consolidate: Process /usr/bin/epiphany was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in epiphany-2.30.2-1.fc13: malloc_consolidate: Process /usr/bin/...
Keywords:
Status: CLOSED DUPLICATE of bug 615502
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b3870a52d38ab48de5f904b2904...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-25 13:42 UTC by jdragone
Modified: 2010-08-26 12:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-26 12:30:48 UTC


Attachments (Terms of Use)
File: backtrace (48.09 KB, text/plain)
2010-06-25 13:43 UTC, jdragone
no flags Details

Description jdragone 2010-06-25 13:42:44 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: epiphany
component: epiphany
crash_function: malloc_consolidate
executable: /usr/bin/epiphany
global_uuid: b3870a52d38ab48de5f904b2904b3f5156daf01f
kernel: 2.6.33.5-124.fc13.x86_64
package: epiphany-2.30.2-1.fc13
rating: 4
reason: Process /usr/bin/epiphany was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

Comment 1 jdragone 2010-06-25 13:43:01 UTC
Created attachment 426885 [details]
File: backtrace

Comment 2 d. johnson 2010-08-26 12:30:48 UTC
There is a known bug (#615502) with epiphany + java-1.6.0-openjdk-plugin that may be affecting you.


You can try removing java-1.6.0-openjdk-plugin and it should no longer crash.


#7  0x000000385567fd28 in IA__g_spawn_async_with_pipes (
    working_directory=<value optimized out>, argv=<value optimized out>, 
    envp=<value optimized out>, flags=<value optimized out>, 
    child_setup=<value optimized out>, user_data=<value optimized out>, 
    child_pid=0x0, standard_input=0x0, standard_output=0x0, standard_error=
    0x0, error=0x7f41359d9220) at gspawn.c:631
        __PRETTY_FUNCTION__ = "IA__g_spawn_async_with_pipes"
#8  0x000000385567fe2c in IA__g_spawn_async (
    working_directory=<value optimized out>, argv=<value optimized out>, 
    envp=<value optimized out>, flags=<value optimized out>, 
    child_setup=<value optimized out>, user_data=<value optimized out>, 
    child_pid=0x0, error=0x7f41359d9220) at gspawn.c:122
        __PRETTY_FUNCTION__ = "IA__g_spawn_async"
#9  0x00007f41357b6133 in plugin_test_appletviewer (
    browserTable=<value optimized out>, pluginTable=<value optimized out>)
    at /usr/src/debug/icedtea6-1.8/plugin/icedteanp/IcedTeaNPPlugin.cc:1501
        error = 0
        command_line = {
    0x23d36b0 "/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/../../bin/java", 0x23d3690 "-version", 0x0}
        environment = 0x23d3ea0
#10 NP_Initialize (browserTable=<value optimized out>, 
    pluginTable=<value optimized out>)
    at /usr/src/debug/icedtea6-1.8/plugin/icedteanp/IcedTeaNPPlugin.cc:2156
        np_error = 0
        filename = 0x23d35f0 "/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64"
        info = {dli_fname = 
    0x23a2f80 "/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so", dli_fbase = 0x7f41357aa000, dli_sname = 
    0x7f41357ad4bb "_Z8ITNP_NewPcP4_NPPtsPS_S2_P12_NPSavedData", dli_saddr = 
    0x7f41357b86e0}
        filename_size = <value optimized out>
#11 0x0000003871994255 in WebCore::PluginPackage::load (this=0x7f4137b62000)
    at WebCore/plugins/gtk/PluginPackageGtk.cpp:153
        NP_Initialize = 
    0x7f41357b5a20 <NP_Initialize(NPNetscapeFuncs*, NPPluginFuncs*)>
        npErr = <value optimized out>
#12 0x000000387199445b in WebCore::PluginPackage::fetchInfo (this=
    0x7f4137b62000) at WebCore/plugins/gtk/PluginPackageGtk.cpp:47
        NP_GetMIMEDescription = <value optimized out>
        NPP_GetValue = <value optimized out>
        buffer = <value optimized out>
        err = <value optimized out>
        types = <value optimized out>
        mimeDescs = <value optimized out>
#13 0x0000003871755c04 in WebCore::PluginPackage::createPackage (path=..., 
    lastModified=@0x7fff3ce53738) at WebCore/plugins/PluginPackage.cpp:159
No locals.
#14 0x000000387174df45 in WebCore::PluginDatabase::refresh (this=
    0x7f41367c7640) at WebCore/plugins/PluginDatabase.cpp:121
        lastModified = 1276592878
        pathsWithTimes = {<WTF::FastAllocBase> = {<No data fields>}, m_impl = 
    {static m_minTableSize = <optimized out>, 
            static m_maxLoad = <optimized out>, 
            static m_minLoad = <optimized out>, m_table = 0x7f4137b57000, 
            m_tableSize = 64, m_tableSizeMask = 63, m_keyCount = 9, 
            m_deletedCount = 0}}
        shouldSkipUnchangedFiles = true
        pluginSetChanged = true
        paths = {<WTF::FastAllocBase> = {<No data fields>}, m_impl = {
            static m_minTableSize = <optimized out>, 
            static m_maxLoad = <optimized out>, 
            static m_minLoad = <optimized out>, m_table = 0x7f4137af7a00, 
            m_tableSize = 64, m_tableSizeMask = 63, m_keyCount = 18, 
            m_deletedCount = 0}}




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 615502 ***


Note You need to log in before you can comment on or make changes to this bug.