Bug 60804 - 404 on package header
404 on package header
Status: CLOSED DUPLICATE of bug 60805
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
All Linux
medium Severity high
: ---
: ---
Assigned To: Chip Turner
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-06 19:18 EST by Isaiah Weiner
Modified: 2015-01-07 18:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-06 19:18:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Isaiah Weiner 2002-03-06 19:18:38 EST
Description of problem:
Package header downloading failed.  Please fix ASAP, or tell me how to fix it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rhn_check -v
2. 

Actual Results:  bash-2.04$ su root -c '/usr/sbin/rhn_check -v'
Password: 
handle_action actionid = 1883947, version = 2
Traceback (innermost last):
  File "/usr/sbin/rhn_check", line 254, in ?
    handle_action(action)
  File "/usr/sbin/rhn_check", line 159, in handle_action
    (status, message, data) = do_call(method, params)   
  File "/usr/sbin/rhn_check", line 72, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 110, in update
    res = batchRun(0, pkgList)
  File "/usr/share/rhn/actions/packages.py", line 122, in batchRun
    ret = wrapper.batchRun(onlyList, [], 0, fromDaemon = 1, actionPkgs = 
pkgList)
  File "/usr/share/rhn/up2date_client/wrapper.py", line 905, in batchRun
    ret = runFromDaemon(pkgNames, actionPkgs, availUpdates, fromDaemon)
  File "/usr/share/rhn/up2date_client/wrapper.py", line 870, in runFromDaemon
    None, None )
  File "/usr/share/rhn/up2date_client/up2date.py", line 1570, in 
getUpdatedPackageList
    refreshCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 827, in getHeaders
    hdr, sourcetype = doCall(headerSource.getHeader, pkg)
  File "/usr/share/rhn/up2date_client/up2date.py", line 313, in doCall
    raise CommunicationError(e.errmsg)
up2date_client.up2date.CommunicationError: Error communicating with server.  
The message was:
404: "Not Found" while attempting to get 
$RHN/cisco-live/getPackageHeader/cisco-sysfiles-2.43-2.noarch.hdr


Expected Results:  No error.

Additional info:
Comment 1 Mihai Ibanescu 2002-03-06 19:27:00 EST

*** This bug has been marked as a duplicate of 60805 ***
Comment 2 Brock Organ 2002-03-21 17:13:19 EST
*** Bug 61404 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.