Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 608071 - fonts.conf doesn't include /usr/share/X11/fonts/misc and applications segfault
fonts.conf doesn't include /usr/share/X11/fonts/misc and applications segfault
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fontconfig (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Marek Kašík
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 11:19 EDT by Aleš Mareček
Modified: 2010-07-16 00:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 00:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleš Mareček 2010-06-25 11:19:51 EDT
Description of problem:
/etc/fonts/fonts.conf doesn't include <dir>/usr/share/X11/fonts/misc</dir> which cause that on installation with Xorg only applications segfault. This is because in config there are:
<dir>/usr/share/X11/fonts/Type1</dir> <dir>/usr/share/X11/fonts/TTF</dir> <dir>/usr/local/share/fonts</dir>
which don't have to be installed (installation without force).

Version-Release number of selected component (if applicable):
fontconfig-2.8.0-1

How reproducible:
Always

Steps to Reproduce:
1. See: https://bugzilla.redhat.com/show_bug.cgi?id=606671#c0
  
Actual results:
No "<dir>/usr/share/X11/fonts/misc</dir>" in /etc/fonts/fonts.conf
Expected results:
"<dir>/usr/share/X11/fonts/misc</dir>" in /etc/fonts/fonts.conf

Additional info:
See more on TK bug, Firefox and Thunderbird bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=606671
https://bugzilla.redhat.com/show_bug.cgi?id=590707
https://bugzilla.redhat.com/show_bug.cgi?id=591481
Comment 1 Bill Nottingham 2010-06-25 12:16:04 EDT
This is intentional, AFAIK, we don't want apps chosing those bitmap fonts.
Comment 2 Bill Nottingham 2010-06-25 12:22:33 EDT
See bug 607057 and https://bugzilla.redhat.com/show_bug.cgi?id=582665#c7.
Comment 3 Marek Kašík 2010-07-02 09:39:45 EDT
There do not have to be any font installed with Xorg. Hence, the application should handle the situation with no font installed itself (or the library which needs it).

Marek
Comment 7 Denise Dumas 2010-07-15 16:21:49 EDT
This use case is just not supported - you must have fonts to use X
Comment 10 RHEL Product and Program Management 2010-07-16 00:34:37 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.