Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 608172 - update to accommodate RHEL6 e2fsprogs fix for FSResizeError: ('resize failed: 1', '/dev/sda2')
update to accommodate RHEL6 e2fsprogs fix for FSResizeError: ('resize failed:...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Brian Lane
Release Test Team
anaconda_trace_hash:daec30a98d670d87d...
: Reopened
: 610758 (view as bug list)
Depends On: 576060 583089
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 17:12 EDT by Brian Lane
Modified: 2013-01-10 01:02 EST (History)
11 users (show)

See Also:
Fixed In Version: anaconda-13.21.58-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 583089
Environment:
Last Closed: 2010-11-10 14:49:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2010-06-25 17:12:40 EDT
+++ This bug was initially created as a clone of Bug #583089 +++

This bug is intended to track a future change to anaconda needed when e2fsprogs is changed to fix bug#576060

+++ This bug was initially created as a clone of Bug #576060 +++

The following was filed automatically by anaconda:
anaconda 13.36 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/fs.py", line 471, in doResize
    raise FSResizeError("resize failed: %s" % rc, self.device)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 348, in execute
    self.device.format.doResize(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 672, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 290, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
FSResizeError: ('resize failed: 1', '/dev/sda2')

<snip>

--- Additional comment from bcl@redhat.com on 2010-04-06 18:07:20 EDT ---

A patch to work around this has been committed to anaconda's master and f13-branch.

As comment 17 says, when the e2fsprogs patch comes through there will need to be another patch to anaconda to deal with the new return code.

--- Additional comment from esandeen@redhat.com on 2010-04-06 18:31:15 EDT ---

(In reply to comment #21)

> As comment 17 says, when the e2fsprogs patch comes through there will need to
> be another patch to anaconda to deal with the new return code.    

I doubt I'll push it pre-F13; it's not upstream yet, and it'd just be more churn for anaconda.  So if it's ok with you guys, you can just not worry about it until F14 :)

-Eric

--- Additional comment from bcl@redhat.com on 2010-04-06 18:37:47 EDT ---

Sounds like a good plan to me.
Comment 3 RHEL Product and Program Management 2010-06-25 17:42:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Brian Lane 2010-06-25 18:07:25 EDT
I had thought this change was causing an error I am seeing in an updated iso I built. It ends up that it is not related to this.
Comment 5 Eric Sandeen 2010-06-29 13:21:32 EDT
Brian, should this be closed NOTABUG then?
Comment 6 Brian Lane 2010-06-29 13:56:50 EDT
Yes. weird, I thought I had already done that, sorry.
Comment 7 Eric Sandeen 2010-06-29 14:10:18 EDT
No prob, thanks.
Comment 8 Brian Lane 2010-07-09 16:46:44 EDT
Re-opening. This needs to be handled correctly.
Comment 9 Brian Lane 2010-07-09 16:47:25 EDT
*** Bug 610758 has been marked as a duplicate of this bug. ***
Comment 10 Brian Lane 2010-07-12 14:30:35 EDT
I have a patch that fixes the UI side of this.

In addition to that there is a problem with the current version of resize2fs (v1.41.12) in that it is requiring a fsck before it will allow -P to report the size. After talking with sandeen we came to the conclusion that this is too strict for -P and should be removed. He is working on that.
Comment 12 Alexander Todorov 2010-07-13 09:19:20 EDT
Steps to reproduce in the duplicate bug:
https://bugzilla.redhat.com/show_bug.cgi?id=610758#c2
Comment 13 Brian Lane 2010-07-13 12:40:27 EDT
anaconda's part will be fixed in 13.21.58-1 commit fe23b3b20f96c739d98db9cfba96310715c05939 and commit bd05db842ba291c5dea6b11b3b1c68c3a03479a0
Comment 15 Alexander Todorov 2010-07-16 11:48:26 EDT
Brian,
following the steps to reproduce from comment #12 lead to a different result with snap #8. Anaconda offers to shrink vda3 and the value for new size is the same as the partition size. When I try to change it to whatever (1000, 0, 1) it's reset back to the original proposal. The increase/descrease arrows are disabled. If I press Shrink with this value then I get a message new size is the same as old size. 

This doesn't look right, does it?
Comment 16 Brian Lane 2010-07-16 12:06:53 EDT
I don't think the new e2fsprogs made it into snap8, so we don't have all the pieces to make it work properly yet.

That is correct behavior for the current set of code though -- it doesn't know what the minimum size is, so is refusing to make it any smaller.
Comment 17 Alexander Todorov 2010-07-19 05:33:40 EDT
Which version of e2fsprogs are we waiting for?
Comment 18 Eric Sandeen 2010-07-19 12:51:06 EDT
(In reply to comment #17)
> Which version of e2fsprogs are we waiting for?    

"the next one" ;)  It'd be 1.41.12-3 if/when I am allowed to make the change:

Bug 614220 - resize2fs: relax -P (query minimum size) requirements

Still waiting on blocker + for that.  qa_ack + might help.
Comment 19 Alexander Todorov 2010-08-10 11:00:07 EDT
(In reply to comment #12)
> Steps to reproduce in the duplicate bug:
> https://bugzilla.redhat.com/show_bug.cgi?id=610758#c2    

With snap #10 (0807.0) and following these steps I was able to shrink vda3 and create LVM layout. Moving to VERIFIED.
Comment 20 releng-rhel@redhat.com 2010-11-10 14:49:12 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.