Bug 614220 - resize2fs: relax -P (query minimum size) requirements
Summary: resize2fs: relax -P (query minimum size) requirements
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: e2fsprogs   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Eric Sandeen
QA Contact: Radek Bíba
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 643945
TreeView+ depends on / blocked
 
Reported: 2010-07-13 21:37 UTC by Eric Sandeen
Modified: 2010-11-10 20:20 UTC (History)
4 users (show)

Fixed In Version: e2fsprogs-1.41.12-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 643945 1183492 (view as bug list)
Environment:
Last Closed: 2010-11-10 20:20:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Sandeen 2010-07-13 21:37:28 UTC
Requesting blocker since anaconda needs this.

We currently have the same restrictions on resize2fs -P (minimum size query) as we do on an actual resize - that is, the fs must be recently checked, cleanly unmounted, and error-free.

To simply query the minimum size, requiring the fsck is a bit draconian; anaconda wants to query this, and requiring a fsck prior to this for each filesystem could take a very long time.  Just ensuring the journal is clean and the fs is not marked with errors should suffice for this, and we can remove the checked-after-last-unmount requirement.

I've sent a patch upstream for this, though it's not yet committed - I don't think I'll encounter resistance.

This is related to bug 608172 which is the anaconda side of the problem.  Having that done now requires this change.

Comment 1 Eric Sandeen 2010-07-19 16:47:58 UTC
The upstream patch was accepted.

http://marc.info/?l=linux-ext4&m=127943687710724&w=2

Comment 2 Eric Sandeen 2010-07-20 16:02:03 UTC
Building e2fsprogs-1.41.12-3.el6 now

Comment 5 releng-rhel@redhat.com 2010-11-10 20:20:47 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.