Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608195 - TypeError: Gtk.Entry.set_text() argument 1 must be string, not None
TypeError: Gtk.Entry.set_text() argument 1 must be string, not None
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
anaconda_trace_hash:f7fbe575ccc5bab6b...
:
Depends On: 580756
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 20:32 EDT by Brian Lane
Modified: 2010-11-10 14:49 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-13.21.55-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 580756
Environment:
Last Closed: 2010-11-10 14:49:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2010-06-25 20:32:58 EDT
+++ This bug was initially created as a clone of Bug #580756 +++

The following was filed automatically by anaconda:
anaconda 13.37.2 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/task_gui.py", line 203, in createDialog
    self.usernameEntry.set_text(self.repo.proxy_username)
  File "/usr/lib/anaconda/iw/task_gui.py", line 527, in _editRepo
    dialog.createDialog()
TypeError: Gtk.Entry.set_text() argument 1 must be string, not None

--- Additional comment from bcl@redhat.com on 2010-04-08 19:52:17 EDT ---

Created an attachment (id=405429)
Attached traceback automatically from anaconda.

--- Additional comment from bcl@redhat.com on 2010-04-08 19:56:09 EDT ---

While testing clumens' patch for bug 580226 I hit this bug in the repo edit dialog. It doesn't like having an empty user passed to it.

Triggered by rebuilding loader with Chris' patch and passing proxy=http://proxy.home:3128 to the kernel while doing a PXE boot of the new build.

--- Additional comment from bcl@redhat.com on 2010-04-08 20:15:52 EDT ---

The same error happens on the password entry when I pass proxy=http://bcl@proxy.home:3128

--- Additional comment from bcl@redhat.com on 2010-04-09 02:13:11 EDT ---

Yum doesn't like it when empty username and password fields are "" instead of None. Submitted a patch that converts to "" on entry to the repo edit dialog and converts "" back to None on exit.

--- Additional comment from rvykydal@redhat.com on 2010-04-09 04:44:52 EDT ---



*** This bug has been marked as a duplicate of bug 572460 ***

--- Additional comment from bcl@redhat.com on 2010-06-25 20:29:14 EDT ---

Created an attachment (id=427017)
Attached traceback automatically from anaconda.
Comment 1 Brian Lane 2010-06-25 20:33:39 EDT
Radek's patch 870dff4fdbbf7e88cfdf46d672ba0b3846aa7d50 will fix this.
Comment 3 RHEL Product and Program Management 2010-06-25 21:02:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Alexander Todorov 2010-07-14 07:50:05 EDT
With snapshot #7 (0707.4 tree) booted with proxy=http://hostname:port. In anaconda UI selecting a repository and then clicking the Modify button shows the repo config dialog. Pressing OK/Cancel closes the dialog. There's no traceback and no username/password is specified. Moving to VERIFIED.
Comment 7 releng-rhel@redhat.com 2010-11-10 14:49:14 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.