Bug 608466 - [abrt] crash in geoclue-0.12.0-1.fc13: cache_ap_mac: Process /usr/libexec/geoclue-master was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in geoclue-0.12.0-1.fc13: cache_ap_mac: Process /usr/libexec/geo...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: geoclue   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:55270b7ed039f9d8d1d0d8a44bb...
Keywords:
: 612281 625118 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-27 17:05 UTC by Brian Lane
Modified: 2018-04-11 11:31 UTC (History)
10 users (show)

Fixed In Version: geoclue-0.12.0-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-23 21:57:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.64 KB, text/plain)
2010-06-27 17:05 UTC, Brian Lane
no flags Details

Description Brian Lane 2010-06-27 17:05:33 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/geoclue-master
component: geoclue
crash_function: cache_ap_mac
executable: /usr/libexec/geoclue-master
global_uuid: 55270b7ed039f9d8d1d0d8a44bb8bfd95d0318f1
kernel: 2.6.33.5-124.fc13.x86_64
package: geoclue-0.12.0-1.fc13
rating: 4
reason: Process /usr/libexec/geoclue-master was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
Enabled locations in Empathy IM client

Comment 1 Brian Lane 2010-06-27 17:05:35 UTC
Created attachment 427238 [details]
File: backtrace

Comment 2 Bastien Nocera 2010-06-29 18:56:04 UTC
I guess you don't use NetworkManager?

Upstream patch:
http://cgit.freedesktop.org/geoclue/commit/?id=bcf9ee4f44625eddad4c267fedc507d9eeeaf3f4

Comment 3 Brian Lane 2010-06-29 19:06:23 UTC
On that machine I'm using wicd instead of NM

Comment 4 Peter Robinson 2010-07-07 19:36:39 UTC
*** Bug 612281 has been marked as a duplicate of this bug. ***

Comment 5 Matěj Cepl 2010-08-18 16:08:41 UTC
*** Bug 625118 has been marked as a duplicate of this bug. ***

Comment 6 Matěj Cepl 2010-08-18 16:09:39 UTC
(In reply to comment #2)
> I guess you don't use NetworkManager?

I do, but it was crashed ATM.

Comment 7 Kaare Fiedler Christiansen 2010-11-03 12:39:08 UTC
Package: geoclue-0.12.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start empathy
2. Click "Edit"->"Preferences"
3. Select tab "Location"
4. Check the button "Publish location to my contacts"


Comment
-----
The crash happened immediately when clicking the checkbox. Empathy stays running, and there were no obvious malfunctions.
I do not know where I can see what my locations information is, so I cannot tell whether my location information is in fact published.

Comment 8 Fedora Update System 2010-11-20 23:33:06 UTC
geoclue-0.12.0-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/geoclue-0.12.0-3.fc14

Comment 9 Fedora Update System 2010-11-20 23:33:20 UTC
geoclue-0.12.0-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/geoclue-0.12.0-3.fc13

Comment 10 Fedora Update System 2010-11-21 22:01:34 UTC
geoclue-0.12.0-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update geoclue'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/geoclue-0.12.0-3.fc14

Comment 11 Fedora Update System 2010-11-23 21:57:23 UTC
geoclue-0.12.0-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-11-29 21:30:21 UTC
geoclue-0.12.0-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.