Bug 60857 - librep needs to require a new gmp
Summary: librep needs to require a new gmp
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: librep   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 60883 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-07 22:51 UTC by Sam Varshavchik
Modified: 2007-04-18 16:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-18 16:26:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sam Varshavchik 2002-03-07 22:51:33 UTC
After doing a 'laptop' install, with Gnome and Development support enabled,
logging in from gdm results in a rather broken desktop.

The following was logged in .xsession-errors:


XIM DEBUG: SESSION_MANAGER=local/laptop.ny.email-scan.com:/tmp/.ICE-unix/1346
aumix:  error opening mixer
rep: received fatal signal: Illegal instruction
rep: received fatal signal: Segmentation fault

Comment 1 Havoc Pennington 2002-03-07 23:03:18 UTC
Works on test machines here. Can you "rpm --verify librep rep-gtk sawfish"
and also double-check versions with "rpm -q librep rep-gtk sawfish"?

Comment 2 Sam Varshavchik 2002-03-08 00:38:14 UTC
The packages verify.

[root@laptop root]# rpm -q librep rep-gtk sawfish
librep-0.15.1-2
rep-gtk-0.15-7
sawfish-1.0.1-4

I temporarily can't strace the X processes, so I can't determine the reason for
the segfault.  I might be having kernel problems. See bug 60863.



Comment 3 Havoc Pennington 2002-03-08 17:27:23 UTC
*** Bug 60883 has been marked as a duplicate of this bug. ***

Comment 4 Chris Ricker 2002-03-09 14:54:58 UTC
I'm seeing the same problem, and so far I can't narrow down what's causing it. 
I get it as both root and normal users on two different machines.  I can provide
a more complete strace than the one in 60883 if it'll be helpful.

Comment 5 lars 2002-03-16 20:25:32 UTC
Just another confirmation:  I installed beta2 on a Sony Vaio 505TX, and I'm
seeing exactly the same problem.  Rep is segfaulting, which prevents sawfish
from starting, which prevents a good portion of Gnome from starting...


Comment 6 Chris Ricker 2002-03-17 19:18:56 UTC
I'm seeing this on a Compaq 12XL125 laptop (K6-III, Trident Cyberblade video). 
I did a clean install of beta2 via NFS, and I get the segfaults for both root
and non-root accounts under multiple kernels (both 2.4.18-0.1, 2.4.18-0.4, and a
recompiled 2.4.18-0.4custom)

Comment 7 Sam Varshavchik 2002-03-17 19:31:36 UTC
My hardware is a five year old "white-box" laptop, with an i586 processor (tried
0.1 i386 kernel), 80MB RAM.  I did a new install, librep segfaults for both root
and a new user account.



Comment 8 Havoc Pennington 2002-03-17 19:36:44 UTC
So far 3 of 3 people describing their hardware say it's a laptop.

Anyone reproducing this on a desktop?

Comment 9 Havoc Pennington 2002-03-17 21:05:42 UTC
Can someone try dropping back to the 7.2 kernel and see if it goes away?

Comment 10 Sam Varshavchik 2002-03-17 22:09:06 UTC
I've booted kernel-2.4.9-31, and librep still faults at startup.



Comment 11 Chris Ricker 2002-03-17 22:22:18 UTC
Ditto for me -- 2.4.9-31 still dies

I've also tried playing with color depth and resolutions.  I normally run the
display at 1152x864x24.  I've tried all combinations of 8, 16, and 24 bit color
and 1024x768 and 1152x864 (the only two resolutions that lcd will do with the
XFree86 4 server), and they all seg-fault.

Comment 12 Chris Ricker 2002-03-18 15:04:08 UTC
Upgrading gmp, per Elliot's suggestion, to gmp-4.0.1-3 from rawhide fixes this
for me

Comment 13 Havoc Pennington 2002-03-18 16:26:04 UTC
OK, reopening to make librep require that version of gmp

Comment 14 Havoc Pennington 2002-03-18 16:42:28 UTC
librep 0.15.1-3 should now require latest gmp


Note You need to log in before you can comment on or make changes to this bug.